TP-Link Archer C50 (EU) V6.0 - 5 GHz interface not present

I would suggest trying a newer version. The image you used is already over 2 years old. Maybe flash support in OpenWRT was improved during this time.

thanks, expert!

Could you please share with me a newer version for this device?

Warmly thank you so much

Thanks, expert for your recommendation of new firmware. I tried to port that file into my device, but unfortunately, it seems not to transfer files by TFTP into my target device, I tried the switch to another port, but it was still the same.

based on your expertise, could you please advise me?

I would recommend reading xristos' posts. Maybe his firmware will also help you:

1 Like

thanks you for your recommendation, I tried that by serval time and switch ports, unfortunately, the error still the same, I cannot port the binary file into Tp-link target router as capture log from ethernet below:


Based on your expertise, I'm willing to hear and advise or suggestion from you
Thank you so much~

The output suggests that your system is not responding to ICMP traffic on 192.168.0.66. You need to take a close look at the instructions on setting up a TFTP server. I think you need to have a system with 192.168.0.66 as the IP address as that's where the device looks for the recovery file.

1 Like

Hi, @jschwart
Maybe I missed something, but I cant access http://files.s-berg.nl/archer-c50-v6/
It says "The requested resource was not found on this server."

What can i do about that?

Hi Leo, it's supposed to show this image:
http://185.203.114.115/static/img/ipv6onlyhosting-ungleich-deadend.jpg

But you're right that server is broken, I removed the reference. There is a AAAA record only now. It will only work if you have IPv6. If you do not have any IPv6 connectivity you can get the latest image here:
https://www.s-berg.nl/files/openwrt-ramips-mt76x8-tplink_archer-c50-v6-squashfs-sysupgrade.bin

Alright, I wish i had IPv6 lol
But thanks for clarifying :slight_smile:

What are the usable channels and channelwidths for the MT7613BEN?
And whats the maximum transmit power?

Hi @leow149, if you have any issues with 5 GHz WiFi. please reply to:

I imagine Hauke might also know the answer to your question. (I can't check myself at this time as I'm in another country.)

MT7613BEN can't do DFS, so ch36-ch48.

Hm, mine is running on channel 149 right now

@jschwart Can you please give us a quick overview/changelog of the pushed commits since the last "released" image?

I don't have such overview myself. You might be able to derive it from the PR. Note that I uploaded a new version today again which matches the current state of the branch/PR.

Dear @jschwart expert!

Thanks for your recommend new binary firmware, it is completed run in my target router. However, it exists a problem with space of "overlay" folder for install new packages with 1.4Mb available, therefore I cannot install Mosquitto SSL (mosquitto-ssl) in this device.


Figure 1: Space of overlay about 1.4Mb


Figure 2: Space of "overlay" is not enough for install mosquitto-ssl package

Based on your expertise, could you please help me how can I increase space of overlay folder or do we have another solutions for install Mosquitto package?

Thank you so much,

Hi @dovanhuong, I understand you also managed to get OpenWRT to work on both your routers now? That's great news!! Thanks a lot for checking it out.

You will probably have to build your own firmware for this and try to reduce it as much as possible. For instance you could not include luci and include the packages you need during the build, Maybe even opkg could be excluded then.

Dear expert,
Thank you for your recommendation, I have a favor could you please help me, do you know where the open source can re-built the image of the router for the tp-link device?
Could you please share with me?
Warmly thank you so much

Here's the branch for the PR:

1 Like

awesome, expert, let's me try it now~