TP-Link Archer C50 (EU) V6.0 - 5 GHz interface not present

Sure you can disable/delete that without issue. I don't think it's even enabled out of the box, but there is the disabled default stuff which you can just remove if you don't need it.

I had the wired switch crash once. Only WiFi was working then and I could find the related stack trace in the kernel messages: TP-Link Archer C50 (EU) V6.0 - 5 GHz interface not present - #74 by jschwart

Maybe you are seeing that too? Of course for things like this it can also be helpful to use the link local address to reach the device as it never changes while you might be making configuration changes to its other addresses.

i cant tell if its the same as i didnt look at it,oute of the box the broadcasting ssids (ability to broadcast you connection through wifi) is present and can be enabled or disabled ,what i am asking is to remove that from the firmware to gain some space.is it doable?is it worth it or its a few kbs so no point doing so,changes made after flashing wont stay/uninstall,it will be present in the rom

I think that should be possible. But then you do really need to set up your own build environment. At the make menuconfig stage you could probably uncheck the AP related items. I have no idea how much space that would give you.

I've bricked my router eeprom but I've got the full 8mb backup...Do you have any idea on how to unlock Winbond W25Q64JVSIQ eeprom from ch341a or any flasher to my TPlink archer c50 v6...

I'm sorry. I never opened up this router and I have no experience at all in this regard. I would suggest looking at similar router models like the earlier Archer C50s and other models listed in target/linux/ramips/image/mt76x8.mk:

I would expect not much information to be available for particularly the C50 v6, but hopefully some of the other TP-Link routers listed there are similar enough and there might be one with information available on this topic.

Are you really sure that TFTP recovery is not possible anymore?

1 Like

Attention all!! Some more adjustments were necessary and these need to be tested. I am in another country than my Archer C50 v6 right now, so I cannot test myself. I created new images and put them in the prior locations:
http://www.s-berg.nl/files/openwrt-ramips-mt76x8-tplink_archer-c50-v6-squashfs-sysupgrade.bin
http://files.s-berg.nl/archer-c50-v6/

It would be great if people could test and confirm everything works with these new images. Please note Hauke's message in the PR:

Could someone please test this device and check if the 5GHz Wifi works fine (more than 10MbIt/s over 5 meters).

You may leave a message directly in the PR or here if you do not have a GitHub account. Many thanks in advance!!

Hi Marssl!

I have the same router TP-Link, but the flash type is XMC, unfortunately, I cannot port this firmware in the router. Could you please advise me on what I should do about this?

the question I placed in this link
https://forum.openwrt.org/t/fail-porting-firmware-in-tp-link-archer-c50-with-flash-xmc25qh64ch10/176086

warmly thank you so much

Could you share more about which firmware image you used? Did you also try the most recent version I provided?

Are you sure that differences are related to the flash memory? What model(s) do you have exactly?

Dear expert!

I confirm that I use the latest version of the binary file you sent.
The binary file I used from this link: https://www.dropbox.com/sh/hwhqt6vsoh96m4m/AAAYx8MgKsOdeA9GTSkyZ-YTa?dl=0

That binary file working well in TP-Link archer C50 V6 with IC flash Windbond

But with TP-Link archer C50 V6 with flash XMC it is the issue with LED blinking and not running.

based on your expertise, could you please advise to me?
Thank you so much

What is the md5sum?

Those are binaries from 2021 and not mine.

Are there any differences between these two models that you can identify apart from what you see inside?

I would suggest reading the topic more carefully or involve somebody that might be more comfortable. There are multiple links to newer binaries including my last post before you joined the conversation. Note that if you do not follow instructions carefully, you can brick your device.

Dear expert!

Thank you for your question, can I answer you as below:

  1. What is the md5sum?
    => I used file: owrt21.02.0rc4-experimental-c50-v6-syssupgrade.bin => This is working well in Tp-Link with IC flash Winbond
    But failed with IC flash XMC
    image

  2. Are there any differences between these two models that you can identify apart from what you see inside?
    => As I check it seems only the IC flash chip is different.

  3. I'm looking around in the OpenWrt forum about this problem, if you have any ideas it will be more appreciated.

Thank you so much~

I would suggest trying a newer version. The image you used is already over 2 years old. Maybe flash support in OpenWRT was improved during this time.

thanks, expert!

Could you please share with me a newer version for this device?

Warmly thank you so much

Thanks, expert for your recommendation of new firmware. I tried to port that file into my device, but unfortunately, it seems not to transfer files by TFTP into my target device, I tried the switch to another port, but it was still the same.

based on your expertise, could you please advise me?

I would recommend reading xristos' posts. Maybe his firmware will also help you:

1 Like

thanks you for your recommendation, I tried that by serval time and switch ports, unfortunately, the error still the same, I cannot port the binary file into Tp-link target router as capture log from ethernet below:


Based on your expertise, I'm willing to hear and advise or suggestion from you
Thank you so much~

The output suggests that your system is not responding to ICMP traffic on 192.168.0.66. You need to take a close look at the instructions on setting up a TFTP server. I think you need to have a system with 192.168.0.66 as the IP address as that's where the device looks for the recovery file.

1 Like

Hi, @jschwart
Maybe I missed something, but I cant access http://files.s-berg.nl/archer-c50-v6/
It says "The requested resource was not found on this server."

What can i do about that?

Hi Leo, it's supposed to show this image:
http://185.203.114.115/static/img/ipv6onlyhosting-ungleich-deadend.jpg

But you're right that server is broken, I removed the reference. There is a AAAA record only now. It will only work if you have IPv6. If you do not have any IPv6 connectivity you can get the latest image here:
https://www.s-berg.nl/files/openwrt-ramips-mt76x8-tplink_archer-c50-v6-squashfs-sysupgrade.bin