TP-Link Archer C2600 V 1.0 Install OpenWrt

Hi people,

Yet another post on the C2600 of which there appear to be alot (I couldnt find any with this issue in particular)

I have spent way too much time trying to get this router running Open WRT this morning. It appears that the firmware is locked down and that I can't load openwrt-19.07.2-ipq806x-generic-tplink_c2600-squashfs-factory.bin (renamed to ArcherC2600_1.0_tp_recovery.bin) to the machine. Is there any hope for it?

I am currently running this version: "Firmware Version:1.0.1 0.9.1 v1000.0 Build 181113 Rel.63116n(5553)". Somehow i downloaded this and it appears to be a global version but i can't find it on the tp-link website now.

I have tried multiple versions of firmware to update this in the hope that it would allow me to put Open WRT. I have tried US, Canadian and global versions from within the web interface (version 15 up through 18) but they all give me a 4503 error: "The uploaded file was not accepted". These are the website I download from:,,

But i still can't get it to do anything through tftp. Should I return this router? I am not really interested in running stock firmware, i use Open WRT to manage my children's DNS so nothing untoward comes up online for them. Is there a modern router that will run Open WRT and doesn't have some weird lockdown?

I have tried in both windows and linux. For windows I set my IP to and netmask to I disabled windows firewall and ran tftpd64 ( from February 28, 2019. I put the Open WRT file in the root directory and renamed it to ArcherC2600_1.0_tp_recovery.bin)

I powered off the router, connected the ethernet between my laptop and LAN1 port. I set tftpd64 to use the loopback ( I held down the reset button on the router and powered it on and then held the reset button for 15 seconds. It never did register the fact that there was a router connected (tftpd64). Then eventually when I boot the router it tells me there is an issue and i have to load the only firmware that works: A10V1_UN-up-ver1-0-1-P1[181113-rel63116].

I have been using Brave, maybe i should try firefox.....

I followed directions I found here:

answered my own question, i purchased the wrong router. I wanted the Archer C2600 but i instead bought the Archer A10 AC2600, no wonder it is not working. Will the Archer A10 ever get Open WRT support?

I bought the same router, having the same issue
why is there no support for this router?

I got the A10 AC2600 Archer Tp-Link .
why is there no support for this?

It has the MT7621AT CPU , so no broadcom chips. i bought the wrong router iguess.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.