TP-Link Archer C2600 performance with 17.01.4


#22

I'm using this one:
r3876-efb6ca1


#23

I tried that. Didn't made a dent.
With SQM cake I can only get 30-70 Mb/s out of 250 Mb/s available.


#24

update for Receive Packet Steering...

Here is a bit of required "massage" for Archer C2600 18.06 release image...

.......

opkg update
opkg install haveged
/etc/init.d/haveged enable

Adjust /etc/sysctl.conf file to have following content

# Defaults are configured in /etc/sysctl.d/* and can be customized in this file
net.core.netdev_max_backlog = 65536
net.core.optmem_max = 65536
net.core.somaxconn = 16384

net.core.rmem_default = 65536
net.core.wmem_default = 65536
net.core.rmem_max = 16777216
net.core.wmem_max = 16777216
net.ipv4.tcp_rmem = 4096 65536 16777216
net.ipv4.tcp_wmem = 4096 65536 16777216

net.core.default_qdisc = fq_codel

net.ipv4.udp_rmem_min = 16384
net.ipv4.udp_wmem_min = 16384

net.ipv4.tcp_fastopen = 3
net.ipv4.tcp_low_latency = 1
net.ipv4.tcp_mtu_probing = 1

net.ipv4.tcp_max_syn_backlog = 65536
net.ipv4.tcp_max_tw_buckets = 65536
net.ipv4.tcp_slow_start_after_idle = 0
net.ipv4.tcp_tw_reuse = 1
net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_timestamps = 1
net.ipv4.tcp_ecn = 1
net.ipv4.tcp_sack = 1
net.ipv4.tcp_dsack = 1

Adjust /etc/rc.local file to have following content

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 10 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

ethtool -K eth0 gro off; sleep 1;
ethttol -K wlan0 gro off; sleep 1;
ethtool -K wlan1 gro off; sleep 1;

ethtool -K eth0 gso off; sleep 1;
ethttol -K wlan0 gso off; sleep 1;
ethtool -K wlan1 gso off; sleep 1;

echo 3 > /sys/class/net/wlan0/queues/rx-0/rps_cpus
echo 3 > /sys/class/net/wlan1/queues/rx-0/rps_cpus

exit 0

reboot

Tests are executed over WERELESS network

Here is outcome with CAKE + piece_of_cake.qos

Here is outcome without CAKE + piece_of_cake.qos

Tests are executed over WIRED network

Here is outcome with CAKE + piece_of_cake.qos

Here is outcome without CAKE + piece_of_cake.qos


#25

Thanks for the info @sjanulonoks ,

Still loosing about 50% of bandwitch using cake.
In my opinion, a dual Core 1.4 Ghz. should be able to handle it (300 Mb and much more).
My old Archer C7v2 (single core 750 Mhz.) was able to manage an 300/300 Mb. fiber connection with SQM ON.

Many thanks for sharing your info!!!!


#26

This "loss" - as you say comes from ISP BufferBloat mostly

Main point of CAKE - to have a reasonable balance between connection and latency.


#27

I don't think so. In my opinion OpenWRT in C2600 is not working properly (performance problems).
Less powerfull routers than C2600 can manage more SQM speeds.


#28

Absolutely not true.
Right now on 17.01 I can get over 200 Mb/s with SQM ON.
On 18.06 I can't really get 100 Mb/s with cake.

I don't know what they broke but in my case even software HW NAT (enabled in firewall) doesn't help.


#29

Hey Klingon...

Wondering your settings were on your C7? I never got close to that w SQM on on mine. Should go off thread, but wanted to get a quick one in there....


#30

My C7 v2 was able to reach about 250 Mb. with SQM ON. Now is running as dumb AP.


#31

Hi @r43k3n

Have you tried lastest versions of 18.06 in your C2600)?
My C2600 is running stock firmware waiting for better times in OpenWRT/LEDE.


#32

My C7 v2 is running (now as AP, before as router) overclocked to 1 Ghz.

[    0.000000] Clocks: CPU:1000.000MHz, DDR:760.000MHz, AHB:380.000MHz, Ref:40.000MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 3822520893 ns
[    0.000005] sched_clock: 32 bits at 500MHz, resolution 2ns, wraps every 4294967295ns
[    0.008501] Calibrating delay loop... 498.89 BogoMIPS (lpj=2494464)

#33

what about delay loop? varies among different architectures? note that 24KC OCed to 1GHz is 666 BogoMIPS. what OC method did you use?


#34

Take a look here: [Solved] Archer C7 V2.0 Overclock

That's the method I used.


#35

Ah, overclocked.... Another question, were you look at top, and checking for 0% idle? Mine at stock speed would deliver up to 250 or more, but with it hard on 0% idle, throttled back to 120-140 would leave a bit of resources.

Now, with 18x.x, or even 17.01.6, it seems like that's dropped to 80-90 over the wifi.... but that's another mystery


#36

I'm running LEDE 17.01.6 and I haven't seen any wifi speed decrease.
My AP is working like a charm. (5 Ghz. band).

Take a look here: [GCC 7.2 BUILD] Optimized TP-Link Archer C7 V2 AC1750 LEDE Firmware


#37

How about you C7 guys create your own topic.

On topic, I'm running latest git and maxing out my 350/350 Mbit internet connection without breaking a sweat.

If you would like to try my build have a look here: Optimized build for the TP-Link C2600 / Netgear R7x00 / Linksys EA8500


#38

Not really, no.
I'm still on 17.01.5 - that's my own build.


#39

Well, have to say I misspoke, after thinking back it was only the 18 release that performed much slower on eth and wifi.

17.01.6 is noticeably slower also, under my eternally variable cable connection, as the home router/NAT/AP. But more like 10-20%, not 40-50%


#40

And, my apologies to the group, I was responding to Klingon thru email, and not realizing it was being echoed in the forum.. will watch for that from now on...


#41

Hi @sjanulonoks you are not using irqbalance package for some reason?