Tp-Link Archer c20i - openwrt installation failed: bricked router - no tftp access

I installed OpenWrt on a Tp-Link c20i, by the browser ( and it didn't work, I did the TFTP restore, turning on the equipment and pressing the WPS / Reset button for a few seconds, it worked d, but the computer was restarted in the middle of the process and now I lost tftp access.

The Router turns on, but only the power light is on, the recovery option no longer works (power button + WPS / Reset), via LAN is distributed ip on sub- mask and no gatway .

I tried to connect Serial to a ttl - USB adapter, used the information from the openWrt wiki to build the cable (Gnd, Rx and Tx pins) (, Attempting to connect via PuTTy by selecting COM port, speed 115200, parity control and flow at "none", the connection happens, but no information is printed on the PuTTY log screen.

Is there still a way to recover this router? I searched the forum for some situations like this, but I was unsuccessful in trying.

Does anyone know how to help me out of this problem?


I think that TP-Links have good procedure for recovery written here:

1 Like