TP-Link Archer C20 V4 how do I go back to stock firmware?


I bought the TP-Link Archer C20 V4, Installed openwrt and tried it out. It is unfortunately not working out for me. The primary issues being,

  1. No support for 5GHz wifi
  2. I have been trying to figure out a way to set it up as a 2.4 Ghz range extender and it's extremely confusing how all of it works.

So, Now I would like to go back to stock firmware. From what I have read so far, I can't simply flash stock firmware over tftp. I need a stripped firmware. I have tried to find a stripped firmware of archer c20 v4 and have came up empty.

So, How do I go back to original firmware?

If you are not able to create a stripped OEM firmware yourself, take a look here:

Thank you soo much!

I use the tp_recovery.bin from that link and that worked just fine for me.


I downloaded the stock firmware and ran binwalk on it. It had 3 files on it. 1. U-Boot image 2. LZMA compressed data 3. Squashfs filesystem

Then, I checked the tp_recovery.bin and it's structure is exactly the same which makes me wonder if I could've used the stock image from official source as tp_recovery.bin.

I also checked the openwrt_sysupgrade.bin but that one has uboot section stripped out of it. I guess, This could've been done by figuring out offsets and stripping it with dd.

Anyway, Thank you so much! I never could've figured out all of that on my own without having access to stripped images in hand.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.