TP-Link archer C2 v1 maxing out at 180mbps

We have recently upgraded our uplink from 100/30mbps to 250/50 here. I was hoping to get the new speed with our current setup, but it seems like the Archer router is the bottleneck. At, I get only around 180mbps max. If I bypass the tplink router and hook straight into the uplink, I get 250-260mbps...

Looking at top during the test shows the CPU is maxed out on softirq, is there a driver setting to tweak so that I can max out the network correctly? Maybe something to offload IRQs or get the driver in polling mode?


I am not sure, but following data from, that router uses at mt7620 chip. Info from Mediateks website says that chip is capable of 2 Gbps routing. Things I can think off that have an impact on speed are having a lot of additional features and packages activated (e.g. Complex Firewall rules, VPN etc.), you connecting via wifi or using software flow offloading. I would try to enable hardware flow offloading (and disable software flow offloading), if that is possible with that hardware and you can find it in Luci. Also use a cable, not wifi to connect to the router and check speeds again.

1 Like

The rule set is pretty simple... just a bastion host and a couple more port forwards.

that however, worked! after checking "Software flow offloading" and then "Hardware flow offloading", i can get 264mbps in! whoohoo!

For those finding this thread later, the setting is under Network -> Firewall -> Routing/NAT Offloading.

(as an aside, why on heart is "Hardware flow offloading" hidden behind "Software flow offloading"? I can't actually "disable software flow offloading", because that hides the "Hardware" button...)

oh of course all this is tested with wires. :slight_smile: i also checked swconfig dev switch0 show and confirmed those were gigabit links.

thanks, this is fixed! :slight_smile:

1 Like

Utter marketing rubbish. You'll never see that in real life.

1 Like

That's correct - need one for the other.

I assumed you enabled HW offloading too when you mentioned software. Glad you got it working!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.