TP-LINK Archer C2 tftp fail - sent DATA <block=1, 0 bytes>

TFTP install from OS X, 10.15. Setup with the instructions here:
IP -
Subnet -
Gateway -

Merged the stock boot and custom binary no problem.

Using official Apple USB > Ethernet adaptor. Model A1277. Tried with router Ethernet ports 1-4.

% tftp 
(also tried sudo tftp)
tftp> binary
tftp> trace
Packet tracing on.
tftp> put final.bin
[plug in router, holding WPS button]
sent WRQ <file=final.bin, mode=octet>
sent WRQ <file=final.bin, mode=octet>
sent WRQ <file=final.bin, mode=octet>
received ACK <block=0>
sent DATA <block=1, 0 bytes>
received ACK <block=1>

I have tried with all the combinations of 10 & 100Mbps, full, half duplex. All same results.

Any help gratefully appreciated!!


you're actually doing it backwards. It can be a bit confusing, so hopefully I can help clarify it...

the router will look for a tftp server at the listed address ( when it is booted into the tftp recovery mode.

The detailed instructions are here

What you need to do:

  1. set your Mac's ethernet port (the USB dongle is fine) in the system preferences > network control panel. Set it to manual and then set the address to and subnet mask of (you can leave the router and gateway fields empty).
  2. copy the file to the correct location and start the tftp service on the mac
sudo cp path/to/file/to/serve.bin /private/tftpboot/the_name_the_device_is_looking_for.bin
sudo launchctl load -F /System/Library/LaunchDaemons/tftp.plist
  1. Boot your router into tftp recover mode (per the directions on the device info page) -- it will automatically download the file from the mac and then reboot.
  2. turn off the tftp server
    sudo launchctl unload -F /System/Library/LaunchDaemons/tftp.plist
  3. set your ethernet adapter on your mac back to automatic / DHCP (if you want it to work 'normally')

Nice one mate, looks like it's got the job done. Thank you SO much! :smiley:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.