TP-Link Archer c2 image installs airos

So, I've been playing with my TP-Link Archer C2 v1. At first, I tried Lede 17.01 from this source: It adds a module for the proprietary (?) wifi-module driver that controls the 5Gzh band. It all installed fine but I couldn't quite get the 5Gzh band to work, I'm not sure why as it showed up in Luci.

Anways, out of curiosity I tried to install an image from here: In the list of snapshots I find a factory image and a sysupgrade one (tplink_c2-v1-squashfs...). I did read the documentation, but the Lede 17.01 firmware would not accept the sysupgrade image.

So, I used TFTP and uploaded the factory image. So far so good. It actually boots. When I hook up my pc via ethernet, and activate DHCP, it asigns me a IP address. I can then ping and ssh the router at Via https, I get a certificate error, but it does open a login page. But here's the bit that I find bewildering:
It opens an "air OS login page". Am I incorrectly under the assumption this is proprietary software that belongs on routers of a different (Ubiquity) brand? The most problematic part: I don't know the log-in credentials. I have tried lots of combinations including "ubtn / ubtn" which is default on these devices. Also; I can no longer get anything flashed using TFTP by holding the WPS button and then switching the device on.

Funnily enough, I can access the internet okay, with the WAN port connected to my ISP's modem.

What to do? And how on earth did I end up with Airos?!

OpenWrt has nothing to do with AirOS. Either you're accessing the wrong device (OpenWrt's default IP is or there is something leftover in your browser cache. Also OpenWrt's web interface is not https unless you do several things to set it up.

You should try the latest official build of OpenWrt, the open wifi drivers have considerably improved since 17.01.


About 17.01 it has wired qurck, you will need to enter , and press save and apply at the bottom of page without change anything to make 5G Wi-Fi work.
and TFTP with normal image will brick your router - it overwrites bootloader and sysupgrade image don't have uboot and normal stock image have 512 Bytes header add so it makes image off-align and make it impossible to boot.
I think you bricked your router and its switch chip works as switch,and you are getting CGNAT addresses from upstream ISP.
from wiki:

creating TFTP recovery image

The C2v1 TFTP recovery overwrites the uboot partition, hence it must be included in a recovery.bin
An official stock TPLink firmware file has a 512 byte header, which needs to be stripped for TFTP:
dd if=c2v1_stock_firmware.bin of=ArcherC2V1_tp_recovery.bin bs=1 skip=512
To create a recovery for openwrt, simply stick the stock uboot in front of the squashfs:
dd if=c2v1_stock_firmware.bin of=c2v1_uboot.bin bs=1 skip=512 count=131072
cat c2v1_uboot.bin openwrt-squashfs-sysupgrade.bin > ArcherC2V1_tp_conf.bin

1 Like

Yes I'd agree with that. It's working as a dumb switch now and you're trying to log into some ISP device further on.

When first setting up a newly flashed router you should connect it with one Ethernet cable only to your PC and not attach to any ISP or other network.

Thanks lads, I think ye are right and my ISP is the one running Airos. Oops! I already thought it odd the device started up so quickly now (makes sense now, it doesn't start up at all).
I did try the "save and apply" thing on the Lan interface page on 17.01 but the signal indicator for 5g would not show anything and it would remain on "frequency: ???". But that was a lot better than what it does now haha.
Is there any way of resetting it now or have I fluffed it up beyond repair? I'll play around with it tonight and have learned my lesson to hook up nothing bar one ethernet wire yea.

I techtically can be done, but that need to open the router and use SIP clip and a rom writer to write directly on the router's rom chip. and they are more expensive than C2 itself.