TP Link Archer A6 (EU)

I've got the Archer A6 v2 (EU), it is to be noted that C6 and A6 are identical at least as per the wiki and other sources.

From the list of supported devices I can notice that Archer A6 v2 (US) uses the C6 v2 (US) firmware, hence I thought to give the A6 (EU) a try by using C6 (EU)'s firmware. I did try to use the Web Interface to install but that returns the error "Invalid File Type" tried both the official release and snapshot (did check the sha256 checksums as well) so I assume I might have to try installing using TFTP.

As per the gitcommit, I followed the instructions to use the TFTP recovery method.

Installed TFTPD
I set my IPV4 to
Pressed on Reset and turned on my router, I wasn't able to get any logs on TFTPD

Another point to note would be that, after so many of my failed attempts, I didn't reset my router. Since my router has one of them pin to reset so initially to test out if the pin works while the router was on I pressed on it and it didn't reset my router, so I'm just surprised so maybe my reset switch is faulty?

Anyways, I maybe be incorrect, looking forward to your support, thanks.

1 Like

This is normal as a single press shouldn't wipe all your settings.
Normally you have to keep it pressed while you power your device on for a factory reset.

Try to figure out if the tftp recovery is searching for another image name.
You can take a look into the tftp server logs or use Wireshark.
With Wireshark you can also determine the used ip addresses and the like...

Ahh thank you for the quick response, okay so I ended up reseting my router to confirm my reset switch works. So using tftpd, I'm actually observing the logs to check if I'm able to establish a connection and to also check whats the file name which my router wants. Do you reckon I use wireshark to check if they've changed the IP from to something else? if thats the case what would be the steps to check.


Edit: I forgot to mention I did try changing the IPV4 to as well and that didn't work as well

So I ended up following this guide on how I can use WireShare to see the IP its requesting. I can see its requesting for and, I then changed my IP respectfully and didn't get get tftp requests. I'm now starting to think weather my router supports tftp or not.

What worked for me:

  • start wireshark, type “udp” in filter without the quotes
  • power off the router, hold the reset button pressed, power on the router and count to 10 slowly
  • release the reset button
  • stop wireshark from collecting packets
  • review the captured packets and see if you can find the ip the router is looking for and adjust accordingly

Some uboot mods look for, some stock firmware look for, other for

1 Like