TP-Link Archer 7 Ver 4 - TFTP Issue


I have installed OpenWrt on a handful of routers. But, I am having issues with the TP-Link Archer 7 that I just purchased. No matter what I do, I cannot seem to get it to go into TFTP mode. I have watched the videos and tried everything that others seem to be trying including following the instructions at:

Also, I tried:

  1. Holding the reset button while subsequently powering on. Wait 5, 10, 15, 20, or more seconds.
  2. Holding the WPS/WiFi button while subsequently powering on. Waiting as in #1.
  3. Powering on and then holding the reset button. Waiting...
  4. Powering on and then holding the reset button. Waiting...

After having no luck, I pulled up Wireshark. My computer IP address is set to I see traffic from my computer. And I see the router at once it powers up with the TP-Link firmware. But, I never see a TFTP request.

I do see the WPS light come on after #1. I have tried releasing the reset button right after it comes on. I also have tried waiting to release it until after the WPS light comes on and then goes back off. When I do that, the power light seems to go off right afterwards. Subsequently, the power light comes back on and the ethernet light comes on (but no wi-fi.) There's an ARP exchange between and And there is a Port 137 NetBIOS packet. Nothing TFTP related, though...

And, yes, I have a TFTP server on my computer and have verified that I can use a client on another computer to transfer the OpenWRT firmware across a network with TFTP.

Ideas? I am lost on this one.

I found out today that some boxes need wps + reset held together before adding power. Did you try that?
And the wiki page you linked to mentions:

For firmware revisions before 3.14.1 (140929) ....

My guess is that if the firmware revision is after 3.14.1 then you might need to attempt to downgrade (if it's not bricked) if possible.
I guess the tftp access was closed in future versions of the firmware as it was deemed an exploit.

Did you try a serial connection?

Is there a reason why don't you want to flash form the stock GUI? I did mine first time that way (mine is v2 though, an it went flawless. Second time I did it from TFTP and it was holding WSP button while turning on, and releasing it when the WPS button flashes.

In recovery mode, the router will be on, if I remember well.

I think this model has only one button for WPS and reset.

@Hegabo Unfortunately, TP-Link has shut down that option.

I will try holding both buttons while powering on. But, I am not too interested in trying serial. I will return the router if I cannot get TFTP to work.

I bought this guy because it was on the recommended list. Maybe we should remove it?