TP-Link AC1300 Archer T3U Plus driver

Hello,

I'm trying to set up my Raspberry Pi 3 as a router and would like to use the TP-Link Archer T3U Plus as a client (or station). I am using the onboard NIC as my access point (AP). However, I'm encountering issues with the Archer T3U Plus. When I run lsusb, it recognizes the device as a Realtek 802.11ac NIC, but it does not appear when I run iw dev or ifconfig -a.

I have tried installing both the rtl8812au and rtl8821ae drivers without success. If anyone has suggestions or solutions, your help would be greatly appreciated.

Thank you!

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/wireless
lsusb -t
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Raspberry Pi 3 Model B Rev 1.2",
        "board_name": "raspberrypi,3-model-b",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "bcm27xx/bcm2710",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'SSID'
        option encryption 'psk2'
        option key 'PASSWORD'
root@OpenWrt:~# lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=, Driver=smsc95xx, 480M
        |__ Port 2: Dev 4, If 1, Class=, Driver=usbhid, 1.5M
        |__ Port 2: Dev 4, If 0, Class=, Driver=usbhid, 1.5M
        |__ Port 4: Dev 6, If 0, Class=, Driver=, 480M
root@OpenWrt:~#

Ok, connected device detected, extract card numbers from lsusb (or connect to ubuntu or fedora and see what driver is detected)

Ok this is what I got from lsusb

Bus 001 Device 006: ID 2357:0138 TP-Link 802.11ac NIC

and I ran sudo lshw -c network | grep rtw for driver details and it returned this

driver=rtw_8822bu

@lolidktbh driver for that adapter is only available on snapshot kmod-rtw88-8822bu
I have one, work for light use, crashes with heavy traffic.

root@OpenWrt:~# lsusb       
Bus 003 Device 003: ID 2357:0138 Realtek 802.11ac NIC
root@OpenWrt:~# lsusb -t
    |__ Port 001: Dev 002, If 0, Class=[unknown], Driver=hub/4p, 480M
        |__ Port 004: Dev 003, If 0, Class=[unknown], Driver=rtw_8822bu, 480M
1 Like

I’m going to use it for my Xbox. I was planning to install OpenVPN because cloud gaming isn't yet supported in my country. I’m not sure what constitutes heavy traffic, but my Xbox usually pulls about 200-300 Mbps. If it can handle that, it should be good enough for me.

Max speed speed I've seen is about 300 Mbps down 180 Mbps up doing speed test, downloading large files will frequently crash.

Ah, okay. I just ran a speed test on my Xbox, and the download speed was 325.24 Mbps and the upload speed was 36 Mbps. Would that be too much for it to handle?

The raspberry pi 3 have USB 2.0 ports, I think speed will be limited about 150Mbs and probably get more stable than on USB 3.0 ports, I have only tested on the Pi5.

Oh, well, that's okay. Cloud gaming only really needs 70-100 Mbps. But is there a way I can compile the rtl8812bu drivers on it? I’ve been working on this for days now.

You have to install snapshot.

ok i will try

Backup config before.

Tutorial: Setting Up TP-Link Archer T3U Plus on OpenWrt Raspberry Pi Router

Hello everyone, I wanted to share a tutorial on how to get the TP-Link Archer T3U Plus network adapter working on your OpenWrt Raspberry Pi router.

Note: The TP-Link Archer T3U Plus is not capable of access point mode, so you will need to use the onboard NIC as your AP if you want to set it up as a wireless router.

Step 1: Install and Flash OpenWrt

  1. Install a snapshot version of OpenWrt for your Raspberry Pi model.
  2. Flash the image onto your SD card and insert it into your Raspberry Pi.

Step 2: Access the Terminal

  1. Access your Raspberry Pi terminal either via SSH or directly.
  2. Set a password by running:
passwd

Step 3: Connect to Wi-Fi (Optional)

If you want to connect to the internet via Wi-Fi instead of Ethernet, follow these steps:

  1. Navigate to the configuration directory:
cd /etc/config
  1. Edit the wireless configuration:
vi wireless
  1. Press i to enter insert mode.
  2. Under config wifi-device 'radio0', change option disabled to '0'.
  3. Under config wifi-iface 'default_radio0', make the following changes:
  • Change option network to 'wan'.
  • Change option mode to 'sta'.
  • Change option ssid to the network you want to connect to (e.g., Steve's Wifi).
  • Change option encryption to 'psk2'.
  • Add a new line option key and set it to your Wi-Fi password (e.g., Stevessafepassword).
  1. Press Esc, then type :wq to save and exit.

Step 4: Configure the WAN Interface

  1. Edit the network configuration:
vi network
  1. Press i to enter insert mode.
  2. Scroll to the bottom and add the following:
config interface 'wan'
    option proto 'dhcp'
  1. Press Esc, then type :wq to save and exit.

Step 5: Finalize Wi-Fi Setup

  1. Commit the wireless configuration:
uci commit wireless
wifi reload
  1. If something pops up and you can't run commands anymore, press Ctrl+C to fix it.
  2. Run ifconfig to verify that your Pi is connected to the internet.

Step 6: Verify and Install Drivers

  1. Update package lists:
opkg update
  1. Verify that your adapter is recognized:
opkg install usbutils
lsusb

You should see Realtek 802.11ac NIC. If not, ensure the adapter is securely plugged in or test it on another machine.
3. Install the driver:

opkg install kmod-rtw88-8822bu

If successful, the driver should load.

Step 7: Configure the Adapter

  1. Edit the wireless configuration again:
vi wireless
  1. Press i to enter insert mode.
  2. Configure Radio 0 (onboard NIC):
  • Set option network to 'lan'.
  • Set option mode to 'ap'.
  • Set option ssid to your desired AP name.
  • For an open network, change option encryption to 'none' and remove the option key line.
  • For a secured network, set option key to your desired AP password.
  1. Configure Radio 2 (TP-Link T3U Plus):
  • Set option disabled to '0'.
  • Set option network to 'wan'.
  • Set option mode to 'sta'.
  • Set option ssid to your Wi-Fi name.
  • Set option encryption to 'psk2'.
  • Add a line option key and set it to your Wi-Fi password.
  1. Press Esc, then type :wq to save and exit.
  2. Finalize the configuration:
uci commit wireless
wifi reload
  1. Press Ctrl+C and run ifconfig to verify that both interfaces are up.

Conclusion

Congratulations! You've successfully set up your TP-Link Archer T3U Plus USB adapter as a station for your Raspberry Pi router.

Additional Setup

LuCI: The Graphical User Interface

To install LuCI, the GUI for your router, run:

opkg install luci
reboot

It's a good idea to create a backup file at this point, so if you mess anything up, you can easily recover.

OpenVPN: Secure Your Wi-Fi Network

To secure your Wi-Fi network with a VPN, I recommend watching this video, which worked flawlessly for me. Note that you need a VPN provider; I recommend ExpressVPN or NordVPN.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.