TP-Link A C6 - Lost connection to Wifi Router (with WAN Connection)

Hi community,

i am new and i need help with me openwrt Router configured as a repeater for an existing Wifi Network.

The structure is as discribed.
One router downstairs is connected with a fiber modem to WAN. I have got the credentials for connecting me with my openwrt Router to repeat my one LAN upstairs.

Router 1 (connected to WAN) has a 192.168.0/24 subnet
Router 2 (my openwrt) has a 192.168.1/24 subnet.

Connected are the routers through the 2,4ghz network. for my subnet i use the 5ghz radio.
First I tried it other way around but had the same issues aswell the 5ghz signal was rarely getting through the basement wall.

i, myself am a informatic technician with basic skills of unix and the use of the commandline via putty.
in "scheduled tasks" (crontab) i put in a restart in the night. but aswell didnt solved my problem.

# Reboot at 4:30am every day
# Note: To avoid infinite reboot loop, wait 70 seconds
# and touch a file in /etc so clock will be set
# properly to 4:31 on reboot before cron starts.
30 4 * * * sleep 70 && touch /etc/banner && reboot

The problem is, that sometimes a day, my router is loosing connection with the other router.
Then i need to restart the router, wait a little while and its working like normal.

In the Systemlog i didnt found any issues.
Is there a log on cmd line which i can upload for troubleshooting?

For explanation reasons: on my router (in my subnet) is the dhcp server (of openwrt) activated.
As well the other router in the different subnet is running a dhcp.

But that are two different subnets and i can reach the WAN Router ip everytime when its working.

Via the diagnostic tool on the webinterface of my openwrt I see that a ipv4 Ping on aswell to the local IP of the WAN Router is not possible.

What can be a reason? What can i try?
Please help me. Any ideas?

Thank you!
Sincerly Hansi