TP-LINK 1900 ONHUB Network interface

Folks / Devs

The default config with upgrade image of Rev 23.05 has interfaces that are bonded with eth0 & eth0.2 (WAN) and eth1 & eth1.1 (LAN).

I tested that eth0.1 and eth1.2 by themselves and there is no apparent need to bond.

The default network file is here:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb5:681d:cd2c::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'br-wan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth0.2'

config interface 'wan'
	option device 'br-wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '2 0t'

You can reset the device.

Yes, that is what I did and it works fine. I was playing around with release 24.10.0 and in this version, it has been fixed. Thank you so much. You are super helpful.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.