Totolink X5000R - how to debrick

Hello everybody.
I just received a Totolink X5000R router and proceeded to flash it with openwrt.
After flashing, the wireless tab was missing in network section, and did not appear after 2 reboots. Also, the /etc/config/wireless file was missing.
Long story short, I just tried to flash the stock oem firmware which was not a .bin and I just bricked it.

I am now trying to find a way to debrick it ,as there is no info about this anywhere.

Could anybody help with some hints?
Is it as simple as trying to flash an openwrt .bin firmware through the serial ttl header?
At the moment, holding the reset button while powering it up does not seem to do anything. The pc will not establish a link to the router.

I'd go for the serial interface ....

Hello. Thanks for the i put. I read a bit on that, and it seems i need to:

  • open the router-not what i wish to do, but if need be, i'll do it.
  • use a usb ttl adapter and use putty to connect the console to the router. Did this before with other devices, and i have a usb ttl adapter.
  • use tftpd server to send a firmware with commands in the console. I have tftpd, but i do not know what firmware to use. Can i just use the openwrt sysupgrade?
  • finally, most important, i see in the guide that some bytes need to be omitted? Is this correct? How do i know if and how many bytes?

Thanks anyways.

Try following this instruction ( i'm not sure it will works):

  • set your pc to static ip: netmask
  • unplug router power, press & hold reset button while plug power for about 15s.
  • run any tftp client & put oem firmware to, example cmd on windows 10: tftp -i PUT firmware_file.web

Hope this helped.

Thank you. I will test this in about 12 hours.

Thank you very much for the input.
I was lucky and my recovery was still up and running. I just set up a static ip in 192.168.1.x subnet and i got access to web recovery at
I flashed the openwrt firmware again and it booted.
Now I have to start another topic, because my wifi is still not showing up.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.