Totolink X5000R deliver wifi speed test at 700Mb

`I just bought the Totolink X5000R because it is the supported ax router. It is very easy to install the stable build using stock web to upgrade the firmware. After setting up, the initial wifi 6 is not reconized . I need to edit the config file and set the country code right. Here is my config for your references.

Here is my config. of the radio1 for your reference.
config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11a'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
option phy 'phy1'
option country 'HK'
option cell_density '0'
option channel '48'
option htmode 'HE80' My internet provide 1 G speed, so the wifi speed at 700Mb is very satisfactory for me.

2 Likes

you're measuring the speed of your internet using speedtest, the wifi itself might be faster.

for the config you posted, select the text and use the </> button on top of the message window.

Yes, you are right, using iperf3, I can get max download speed up to 778Mb

Given the SoC (MT7621) I'd say that's pretty good results however you're most likely pegging the SoC at these speeds.

If you use 21.02.1 version try with the snapshot version which has no problem for the WIFI AX

I have same problem when i build all my routers AX with 21.02.1

Thanks. Actually I get ax works fine with the stable build. No need to use snapshot version. What I do is edit the network config to make it works.

What did you change in your config?

Here's what is working for me on 21.02.1:

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option cell_density '0'
	option noscan '1'
	option hwmode '11g'
	option channel 'auto'
	option htmode 'HE40'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option cell_density '0'
	option hwmode '11a'
	option htmode 'VHT80'
	option country 'US'

And for >21.02.2:

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option cell_density '0'
	option noscan '1'
	option band '5g'
	option channel 'auto'
	option htmode 'HE40'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option cell_density '0'
	option band '5g'
	option htmode 'VHT80'
	option country 'US'

There are still few bugs as of 21.02.2:

  1. LUCI still doesn't really work for setting wifi config on this device, so don't bother with it. It will break your configuration and not allow you to choose correct settings.
  2. I don't know if option band '5g' is actually enabling 802.11ax mode, it appears to be 802.11ac only.
  3. VHT160 isn't working, the hardware never comes back up after it is enabled.
1 Like

I am using the latest development snapshot.

  1. For Radio0 (2.4GHz)
  • need to add option noscan '1' for HE40 to work
  1. For Radio1 (5GHz)
  • VHT160 do not work (radio not detected)

The speed test result of OpenWrt is lower than OEM firmware.

Did you test HE80 value for 5Ghz radio?

Test with snapshot

https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-totolink_x5000r-squashfs-sysupgrade.bin

I tested with VHT80, which it works. HE80 also works (with same speed)

The default config is missing band '5g', which makes 5Ghz wifi not working initially.

This is testing on that snapshot with default settings

totolink_x5000r-squashfs-sysupgrade.bin	0e32463b081e6e2f1307d08aa8477d9a8ee643a07fe90cd15f395abcdc682328	6400.6 KB	Fri Mar 18 20:40:32 2022
root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HE20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option channel '36'
	option band '5g'
	option htmode 'HE80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

I only install luci-ssl by:

opkg update; opkg install luci-ssl

Then via Luci->Wireless, I only enable the 5Ghz radio1.

My notebook can connect to OpenWrt SSID. Connect speed is normal range of HE80.

There is a difference between HE180 vs VHT180 in radio1:

  • wtih HE180, SSID is detected, but connection failed
  • with VHT180, SSID is not detected.

I have set:

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option cell_density '0'
	option hwmode '11a'
	option band '5g'
	option htmode 'HE80'

and it works fine with both as well 2.4 as 5Ghz for now.