Tor not working on lede 17.01.4

Hello eduperez,

I think my account is too new. The system is saying I cannot send you an pm. Would it be ok to receive a pm from you when time permits?

Thank you.

Sincerely,

A humbly committed student.

Let's make it easy! I just uploaded the files to my Dropbox account:

Thank you brother!

I will keep you and the community posted on any break throughs.

Hello Community,

As promised, I was going to update you all on my tor project. I am pleased to report that I was able to get tor working. I will post my step-by-step procedure here to help others who were not able to get this working. If there are any configurations, feedback, or methods and easier ways to do what I have done then please provide your updates to the community. If this is not a proper location to post this then please let me know if I need to create a new post entirely. I figured this was a working solution that was in line with the original poster's problem.

Important note: LEDE 17.01.4 had a some bugs so I used the newer 18 version of the os here.

Let me begin.

Here are the configuration files:

  1. I edited the following in my network config file with
    vi /etc/config/network
    and inputted the information in the line 'tor'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde7:49b5:0078::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'slave'
        option type 'bridge'
        option proto 'static'
        option ipaddr '172.16.0.1'
        option netmask '255.255.0.0'

config interface 'tor'
        option proto 'static'
        option ipaddr '10.1.1.1'
        option netmask '255.0.0.0'
        option type 'bridge'

config interface 'vpnserver'
        option proto 'none'
        option ifname 'ovpns0'
        option auto '1'

  1. Next I configured its dhcp with
vi /etc/config/dhcp

again notice the section for "tor":


config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option serversfile '/tmp/adb_list.overall'
        list server '8.8.8.8'
        list server '8.8.4.4'

config dhcp 'lan'
        option interface 'lan'
        option start '2'
        option limit '254'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'slave'
        option leasetime '12h'
        option interface 'slave'
        option start '2'
        option limit '254'

config dhcp 'tor'
        option leasetime '12h'
        option interface 'tor'
        option start '2'
        option limit '254'

  1. I then created the wireless interface that will be connecting clients to the tor network and bridged to the tor interface created in step 1. Later on, I plan to create vlans for other switches and wifi repeaters to be on the same tor network interface but i digress.
vi /etc/config/wireless

again notice the section configured under "tor" (edited to remove confidential information for security purposes).


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'US'
        option legacy_rates '1'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Magick Mushroom'
        option key 'supersecretpassword'
        option encryption 'psk-mixed'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'Magick Mushroom'
        option encryption 'supersecretpassword'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option encryption 'none'
        option ssid 'slave'
        option network 'slave'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option encryption 'none'
        option ssid 'tor'
        option network 'tor'


  1. Next I edited my firewall settings to accommodate the tor network
vi /etc/config/firewall

Study the tor section and forwarding rules respectively.

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'slave'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'slave'
        option input 'REJECT'

config forwarding
        option dest 'wan'
        option src 'slave'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp'
        option dest_port '22'
        option name 'Allow-SSH-WAN'
        option enabled '0'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp'
        option name 'Allow-HTTPS-WAN'
        option dest_port '443'
        option enabled '0'

config rule
        option target 'ACCEPT'
        option proto 'tcp udp'
        option dest_port '53'
        option name 'Slave dns'
        option src 'slave'

config rule
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '67-68'
        option name 'slave dhcp'
        option src 'slave'

config zone
        option name 'tor'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'tor'
        option input 'ACCEPT'
        option syn_flood '1'
        option conntrack '1'

config forwarding
        option dest 'wan'
        option src 'tor'

config forwarding
        option src 'wan'
        option dest 'tor'

config rule
        option src 'tor'
        option proto 'udp'
        option dest_port '67'
        option target 'ACCEPT'

config rule
        option src 'tor'
        option proto 'tcp'
        option dest_port '9040'
        option target 'ACCEPT'

config rule
        option src 'tor'
        option proto 'udp'
        option dest_port '9053'
        option target 'ACCEPT'

config redirect
        option name 'Redirect-Tor-Traffic'
        option src 'tor'
        option src_dip '!10.1.1.1'
        option dest_port '9040'
        option proto 'tcp'
        option target 'DNAT'

config redirect
        option name 'Redirect-Tor-DNS'
        option src 'tor'
        option src_dport '53'
        option dest_port '9053'
        option proto 'udp'
        option target 'DNAT'
  1. I then edited the firewall.user file that is referrenced.
vi /etc/firewall.user

I added two lines for iptables config for the wireless interface and the portnumbers tor uses:

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.

iptables -t nat -A PREROUTING -i wlan1-2 -p udp --dport 53 -j REDIRECT --to-ports 9053
iptables -t nat -A PREROUTING -i wlan1-2 -p tcp --syn -j REDIRECT --to-ports 9040

  1. I decided to download and install tor first before creating the torrc file
opkg update; opkg install tor tor-geoip
  1. Once the directory and files was created, I edited it
vi /etc/tor/torrc

Notice the areas where I removed the comments and the rest of the configurations I added to the bottom of the file

## Configuration file for a typical Tor user
## Last updated 22 December 2017 for Tor 0.3.2.8-rc.
## (may or may not work for much older or much newer versions of Tor.)
##
## Lines that begin with "## " try to explain what's going on. Lines
## that begin with just "#" are disabled commands: you can enable them
## by removing the "#" symbol.
##
## See 'man tor', or https://www.torproject.org/docs/tor-manual.html,
## for more options you can use in this file.
##
## Tor will look for this file in various places based on your platform:
## https://www.torproject.org/docs/faq#torrc

## Tor opens a SOCKS proxy on port 9050 by default -- even if you don't
## configure one below. Set "SOCKSPort 0" if you plan to run Tor only
## as a relay, and not make any local application connections yourself.
#SOCKSPort 9050 # Default: Bind to localhost:9050 for local connections.
#SOCKSPort 192.168.0.1:9100 # Bind to this address:port too.

## Entry policies to allow/deny SOCKS requests based on IP address.
## First entry that matches wins. If no SOCKSPolicy is set, we accept
## all (and only) requests that reach a SOCKSPort. Untrusted users who
## can access your SOCKSPort may be able to learn about the connections
## you make.
#SOCKSPolicy accept 192.168.0.0/16
#SOCKSPolicy accept6 FC00::/7
#SOCKSPolicy reject *

## Logs go to stdout at level "notice" unless redirected by something
## else, like one of the below lines. You can have as many Log lines as
## you want.
##
## We advise using "notice" in most cases, since anything more verbose
## may provide sensitive information to an attacker who obtains the logs.
##
## Send all messages of level 'notice' or higher to /var/log/tor/notices.log
Log notice file /var/log/tor/notices.log
## Send every possible message to /var/log/tor/debug.log
#Log debug file /var/log/tor/debug.log
## Use the system log instead of Tor's logfiles
Log notice syslog
## To send all messages to stderr:
#Log debug stderr

## Uncomment this to start the process in the background... or use
## --runasdaemon 1 on the command line. This is ignored on Windows;
## see the FAQ entry if you want Tor to run as an NT service.
RunAsDaemon 1

## The directory for keeping all the keys/etc. By default, we store
## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
DataDirectory /var/lib/tor

## The port on which Tor will listen for local connections from Tor
## controller applications, as documented in control-spec.txt.
#ControlPort 9051
## If you enable the controlport, be sure to enable one of these
## authentication methods, to prevent attackers from accessing it.
#HashedControlPassword 16:872860B76453A77D60CA2BB8C1A7042072093276A3D701AD684053EC4C
#CookieAuthentication 1

############### This section is just for location-hidden services ###

## Once you have configured a hidden service, you can look at the
## contents of the file ".../hidden_service/hostname" for the address
## to tell people.
##
## HiddenServicePort x y:z says to redirect requests on port x to the
## address y:z.

#HiddenServiceDir /var/lib/tor/hidden_service/
#HiddenServicePort 80 127.0.0.1:80

#HiddenServiceDir /var/lib/tor/other_hidden_service/
#HiddenServicePort 80 127.0.0.1:80
#HiddenServicePort 22 127.0.0.1:22

################ This section is just for relays #####################
#
## See https://www.torproject.org/docs/tor-doc-relay for details.

## Required: what port to advertise for incoming Tor connections.
#ORPort 9001
## If you want to listen on a port other than the one advertised in
## ORPort (e.g. to advertise 443 but bind to 9090), you can do it as
## follows.  You'll need to do ipchains or other port forwarding
## yourself to make this work.
#ORPort 443 NoListen
#ORPort 127.0.0.1:9090 NoAdvertise

## The IP address or full DNS name for incoming connections to your
## relay. Leave commented out and Tor will guess.
#Address noname.example.com

## If you have multiple network interfaces, you can specify one for
## outgoing traffic to use.
## OutboundBindAddressExit will be used for all exit traffic, while
## OutboundBindAddressOR will be used for all OR and Dir connections
## (DNS connections ignore OutboundBindAddress).
## If you do not wish to differentiate, use OutboundBindAddress to
## specify the same address for both in a single line.
#OutboundBindAddressExit 10.0.0.4
#OutboundBindAddressOR 10.0.0.5

## A handle for your relay, so people don't have to refer to it by key.
## Nicknames must be between 1 and 19 characters inclusive, and must
## contain only the characters [a-zA-Z0-9].
#Nickname ididnteditheconfig

## Define these to limit how much relayed traffic you will allow. Your
## own traffic is still unthrottled. Note that RelayBandwidthRate must
## be at least 75 kilobytes per second.
## Note that units for these config options are bytes (per second), not
## bits (per second), and that prefixes are binary prefixes, i.e. 2^10,
## 2^20, etc.
#RelayBandwidthRate 100 KBytes  # Throttle traffic to 100KB/s (800Kbps)
#RelayBandwidthBurst 200 KBytes # But allow bursts up to 200KB (1600Kb)

## Use these to restrict the maximum traffic per day, week, or month.
## Note that this threshold applies separately to sent and received bytes,
## not to their sum: setting "40 GB" may allow up to 80 GB total before
## hibernating.
##
## Set a maximum of 40 gigabytes each way per period.
#AccountingMax 40 GBytes
## Each period starts daily at midnight (AccountingMax is per day)
#AccountingStart day 00:00
## Each period starts on the 3rd of the month at 15:00 (AccountingMax
## is per month)
#AccountingStart month 3 15:00

## Administrative contact information for this relay or bridge. This line
## can be used to contact you if your relay or bridge is misconfigured or
## something else goes wrong. Note that we archive and publish all
## descriptors containing these lines and that Google indexes them, so
## spammers might also collect them. You may want to obscure the fact that
## it's an email address and/or generate a new address for this purpose.
##
## If you are running multiple relays, you MUST set this option.
##
#ContactInfo Random Person <nobody AT example dot com>
## You might also include your PGP or GPG fingerprint if you have one:
#ContactInfo 0xFFFFFFFF Random Person <nobody AT example dot com>

## Uncomment this to mirror directory information for others. Please do
## if you have enough bandwidth.
#DirPort 9030 # what port to advertise for directory connections
## If you want to listen on a port other than the one advertised in
## DirPort (e.g. to advertise 80 but bind to 9091), you can do it as
## follows.  below too. You'll need to do ipchains or other port
## forwarding yourself to make this work.
#DirPort 80 NoListen
#DirPort 127.0.0.1:9091 NoAdvertise
## Uncomment to return an arbitrary blob of html on your DirPort. Now you
## can explain what Tor is if anybody wonders why your IP address is
## contacting them. See contrib/tor-exit-notice.html in Tor's source
## distribution for a sample.
#DirPortFrontPage /etc/tor/tor-exit-notice.html

## Uncomment this if you run more than one Tor relay, and add the identity
## key fingerprint of each Tor relay you control, even if they're on
## different networks. You declare it here so Tor clients can avoid
## using more than one of your relays in a single circuit. See
## https://www.torproject.org/docs/faq#MultipleRelays
## However, you should never include a bridge's fingerprint here, as it would
## break its concealability and potentially reveal its IP/TCP address.
##
## If you are running multiple relays, you MUST set this option.
##
#MyFamily $keyid,$keyid,...

## Uncomment this if you do *not* want your relay to allow any exit traffic.
## (Relays allow exit traffic by default.)
#ExitRelay 0

## Uncomment this if you want your relay to allow IPv6 exit traffic.
## (Relays only allow IPv4 exit traffic by default.)
#IPv6Exit 1

## A comma-separated list of exit policies. They're considered first
## to last, and the first match wins.
##
## If you want to allow the same ports on IPv4 and IPv6, write your rules
## using accept/reject *. If you want to allow different ports on IPv4 and
## IPv6, write your IPv6 rules using accept6/reject6 *6, and your IPv4 rules
## using accept/reject *4.
##
## If you want to _replace_ the default exit policy, end this with either a
## reject *:* or an accept *:*. Otherwise, you're _augmenting_ (prepending to)
## the default exit policy. Leave commented to just use the default, which is
## described in the man page or at
## https://www.torproject.org/documentation.html
##
## Look at https://www.torproject.org/faq-abuse.html#TypicalAbuses
## for issues you might encounter if you use the default exit policy.
##
## If certain IPs and ports are blocked externally, e.g. by your firewall,
## you should update your exit policy to reflect this -- otherwise Tor
## users will be told that those destinations are down.
##
## For security, by default Tor rejects connections to private (local)
## networks, including to the configured primary public IPv4 and IPv6 addresses,
## and any public IPv4 and IPv6 addresses on any interface on the relay.
## See the man page entry for ExitPolicyRejectPrivate if you want to allow
## "exit enclaving".
##
#ExitPolicy accept *:6660-6667,reject *:* # allow irc ports on IPv4 and IPv6 but no more
#ExitPolicy accept *:119 # accept nntp ports on IPv4 and IPv6 as well as default exit policy
#ExitPolicy accept *4:119 # accept nntp ports on IPv4 only as well as default exit policy
#ExitPolicy accept6 *6:119 # accept nntp ports on IPv6 only as well as default exit policy
#ExitPolicy reject *:* # no exits allowed

## Bridge relays (or "bridges") are Tor relays that aren't listed in the
## main directory. Since there is no complete public list of them, even an
## ISP that filters connections to all the known Tor relays probably
## won't be able to block all the bridges. Also, websites won't treat you
## differently because they won't know you're running Tor. If you can
## be a real relay, please do; but if not, be a bridge!
#BridgeRelay 1
## By default, Tor will advertise your bridge to users through various
## mechanisms like https://bridges.torproject.org/. If you want to run
## a private bridge, for example because you'll give out your bridge
## address manually to your friends, uncomment this line:
#PublishServerDescriptor 0

## Configuration options can be imported from files or folders using the %include
## option with the value being a path. If the path is a file, the options from the
## file will be parsed as if they were written where the %include option is. If
## the path is a folder, all files on that folder will be parsed following lexical
## order. Files starting with a dot are ignored. Files on subfolders are ignored.
## The %include option can be used recursively.
#%include /etc/torrc.d/
#%include /etc/torrc.custom

User tor
PidFile /var/run/tor.pid
Log notice file /var/log/tor/notices.log
Log debug file /var/log/tor/debug.log
GeoIPFile /usr/share/tor/geoip
GeoIPv6File /usr/share/tor/geoip6
MaxCircuitDirtiness 60
ExitNodes {us}
StrictNodes 1

VirtualAddrNetworkIPv4 10.192.0.0/10
AutomapHostsSuffixes .onion,.exit
AutomapHostsOnResolve 1

TransPort 10.1.1.1:9040

DNSPort 10.1.1.1:9053

SocksPort 10.1.1.1:9050
#SocksBindAddress 192.168.2.1:9050
#SocksBindAddress 192.168.1.1:9050

  1. reboot the router
reboot now
  1. to verify you can check if the process is running by
ps -ef | grep -i tor

and output should resemble this

tor       4726     1  0 Jun25 ?        00:01:23 /usr/sbin/tor --runasdaemon 0
root     13093 21825  0 02:33 pts/0    00:00:00 grep -i tor
  1. similarly you can tail the log to see the following output
tail -f /tmp/log/tor

notice "Tor has successfully opened a circuit. Looks like client functionality is working."

Jun 25 07:18:12.000 [notice] Tor 0.3.2.10 (git-31cc63deb69db819) opening new log file.
Jun 25 07:18:12.000 [notice] Tor 0.3.2.10 (git-31cc63deb69db819) opening log file.
Jun 25 07:18:12.589 [notice] Tor 0.3.2.10 (git-31cc63deb69db819) running on Linux with Libevent 2.0.22-stable, OpenSSL 1.0.2o, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
Jun 25 07:18:12.589 [notice] Tor 0.3.2.10 (git-31cc63deb69db819) running on Linux with Libevent 2.0.22-stable, OpenSSL 1.0.2o, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
Jun 25 07:18:12.590 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jun 25 07:18:12.590 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jun 25 07:18:12.594 [notice] Read configuration file "/etc/tor/torrc".
Jun 25 07:18:12.594 [notice] Read configuration file "/etc/tor/torrc".
Jun 25 07:18:12.662 [notice] You configured a non-loopback address '10.1.1.1:9053' for DNSPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.662 [notice] You configured a non-loopback address '10.1.1.1:9053' for DNSPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.663 [notice] You configured a non-loopback address '10.1.1.1:9040' for TransPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.663 [notice] You configured a non-loopback address '10.1.1.1:9040' for TransPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.696 [notice] Scheduler type KIST has been enabled.
Jun 25 07:18:12.696 [notice] Scheduler type KIST has been enabled.
Jun 25 07:18:12.696 [notice] You configured a non-loopback address '10.1.1.1:9050' for SocksPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.696 [notice] You configured a non-loopback address '10.1.1.1:9050' for SocksPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.696 [notice] You configured a non-loopback address '10.1.1.1:9053' for DNSPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.696 [notice] You configured a non-loopback address '10.1.1.1:9053' for DNSPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.696 [notice] You configured a non-loopback address '10.1.1.1:9040' for TransPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.696 [notice] You configured a non-loopback address '10.1.1.1:9040' for TransPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Jun 25 07:18:12.701 [notice] Opening Socks listener on 10.1.1.1:9050
Jun 25 07:18:12.701 [notice] Opening Socks listener on 10.1.1.1:9050
Jun 25 07:18:12.706 [notice] Opening DNS listener on 10.1.1.1:9053
Jun 25 07:18:12.706 [notice] Opening DNS listener on 10.1.1.1:9053
Jun 25 07:18:12.707 [notice] Opening Transparent pf/netfilter listener on 10.1.1.1:9040
Jun 25 07:18:12.707 [notice] Opening Transparent pf/netfilter listener on 10.1.1.1:9040
Jun 25 07:19:17.000 [notice] Bootstrapped 50%: Loading relay descriptors
Jun 25 07:19:17.000 [notice] Bootstrapped 50%: Loading relay descriptors
Jun 25 07:19:20.000 [notice] Bootstrapped 58%: Loading relay descriptors
Jun 25 07:19:20.000 [notice] Bootstrapped 58%: Loading relay descriptors
Jun 25 07:21:20.000 [notice] Bootstrapped 67%: Loading relay descriptors
Jun 25 07:21:20.000 [notice] Bootstrapped 67%: Loading relay descriptors
Jun 25 07:21:21.000 [notice] Bootstrapped 73%: Loading relay descriptors
Jun 25 07:21:21.000 [notice] Bootstrapped 73%: Loading relay descriptors
Jun 25 07:21:21.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Jun 25 07:21:21.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Jun 25 07:21:21.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Jun 25 07:21:21.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Jun 25 07:21:24.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Jun 25 07:21:24.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
  1. Try connecting to the newly created tor wifi and test its connectivity with check tor
    https://cdn.instructables.com/FHN/5956/IK2X86XF/FHN5956IK2X86XF.LARGE.jpg

  2. if you ever need to start and stop the tor service:

/etc/init.d/tor start
/etc/init.d/tor stop
/etc/init.d/tor restart
  1. you can also find the process number from the ps -ef | grep -i tor and kill ### its pid number

Again, thank you for all the help community and let me know any feedback.

Sincerely,

A humbly committed student

3 Likes

Hello.
I have gl - ar300 m with LuCI lede-17.01 branch (git-17.290.79498-d3f0685) / LEDE Reboot 17.01.4 r3560-79f57e422d
and i try install TOR there.
i have downloaded these:
tor 0.2.9.10-1
tor-gencert 0.2.9.10-1
tor-geoip 0.2.9.10-1
tor-resolve 0.2.9.10-1
and then i dont know what to do. sorry i am very new.
better for me - using GUI.

Could somebody help me please?

See the step by step instructions just above your posting:

Thank you for the dedication to this. I got it working on my network following this guide.

Definitely works on my setup.

**Hostname**
OpenWrt
**Model**
Linksys WRT3200ACM
**Architecture**
ARMv7 Processor rev 1 (v7l)
**Firmware Version**
OpenWrt 18.06.0 r7188-b0b5c64c22 / LuCI openwrt-18.06 branch (git-18.210.69179-6df9a57)
**Kernel Version**
4.14.54
1 Like

@unitelife Since your guide seems to be working quite well and since we currently have no such guide in the OpenWrt wiki: Can I import your guide into the wiki?

1 Like

I would be honored.

https://openwrt.org/docs/guide-user/services/tor/start has been created.

Since this topic refers to (quite old) 17.01.4, I'm closing this topic now.
Please open new topics for any remaining questions.

Thanks tmomas!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.