/tmp/resolv.conf and search entrys

Hi,

I have two APs which dont need to run dnsmasq. I want to configure there the /etc/resolv.conf with a search list, so that I don't need to use fqdn all the time. Example to ping a host in my network with ping mypc and not with ping mypc.home.lan...

I tested to configure my interfaces with luci and use the dns_search option which are present in luci (21.02-rc4) - but this seems the be ignored.

I also tested to use dnsmasq option noresolv '1' and also option add_local_domain '0' without luck.

my interfaces are configured like this:

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.99.252'
        option netmask '255.255.255.0'
        option gateway '192.168.99.1'
        list dns '192.168.99.1'
        option delegate '0'
        option ip6ifaceid '::252'
        option dns_metric '2'
        option metric '2'
        list dns_search 'home.lan'

config interface 'lan6'
        option device '@lan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'no'
        option delegate '0'
        option ip6ifaceid '::252'
        option dns_metric '2'
        option metric '2'

config interface 'guest'
        option device 'br-guest'
        option proto 'static'
        option ipaddr '192.168.189.252'
        option netmask '255.255.255.0'
        option delegate '0'
        option ip6ifaceid '::252'
        option dns_metric '3'
        option metric '3'
        list dns_search 'guest.lan'

config interface 'guest6'
        option device '@guest'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'no'
        option delegate '0'
        option ip6ifaceid '::252'
        option dns_metric '3'
        option metric '3'

Any hints?

You need to configure all the required search domains on the client side.
If you have a Linux system with NetworkManager, it can be done like this:

nmcli connection modify id CON_NAME ipv4.dns-search home.lan,guest.lan
nmcli connection up id CON_NAME 

my clients are on this case the openwrt access points - there I want this....

uci -q delete network.lan.dns_search
uci -q delete network.guest.dns_search
uci add_list network.lan.dns_search="home.lan guest.lan"
uci commit network
/etc/init.d/network restart

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.