TL-XDR6088 CPU usage

I am using TP-Link TL-XDR6088. I have added the CPU usage to check the CPU usage of wired connection speed and wireless connection speed. I have turned on Flow offloading . Is the wireless part not enabled successfully? Wired connection It was activated successfully One is wired and the other is wireless


Can you post links to reports without offload with soft offload
With hard offload as now, then after enabling WED using:
https://www.waveform.com/tools/bufferbloat

cat /sys/module/mt7915e/parameters/wed_enable
echo Y > /sys/module/mt7915e/parameters/wed_enable
service firewall restart
# save permanently
echo options mt7915e wed_enable=Y | tee -a /etc/modules.conf

You can observe OpenWRT CPU usage with htop

There is no difference between enabling hard uninstall and soft uninstall. I have tested them several times and they are all the same.

If WED enabled is stable for few days then keep it.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/firewall

I would like to ask how to enable WED, thank you

root@DE:~# ubus call system board
{
        "kernel": "6.6.58",
        "hostname": "DESKTOP-6J0M9NF",
        "system": "ARMv8 Processor rev 4",
        "model": "TP-Link TL-XDR6088",
        "board_name": "tplink,tl-xdr6088",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "description": "OpenWrt SNAPSHOT",
                "revision": "r27996-1c62f5b585",
                "target": "mediatek/filogic",
                "builddate": "1729790068"
        }
}

root@DE:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf3:ef1e:366::/48'
        option packet_steering '2'
        option steering_flows '256'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

root@DE:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option band '2g'
        option channel '8'
        option htmode 'HE40'
        option disabled '0'
        option country 'CN'
        option cell_density '0'
        option noscan '1'
        option txpower '23'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'TP-LINK2.4G'
        option encryption 'sae-mixed'
        option disassoc_low_ack '0'
        option key '********'
        option ocv '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option band '5g'
        option channel '40'
        option htmode 'HE160'
        option disabled '0'
        option country 'CN'
        option cell_density '0'
        option txpower '23'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'TP-LINK5G'
        option encryption 'sae-mixed'
        option disassoc_low_ack '0'
        option key '********'
        option ocv '0'

root@DE:~# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'


Enable WED?

https://www.waveform.com/tools/bufferbloat?test-id=5a710166-7671-4f98-91b8-3b019004244e

OK, your internet connection has a (serious) bufferbloat problem.
For 200+100Mbps you actually do not need any offload, just a SQM (or any other traffic control)

Do you want to stay on snapshot or downgrade to stable 23.05.5?

My access is 1G, but the speed of wifi is not as fast as the wired connection. I want to use snapshot

luci-app-qosmate or luci-app-sqm

Recipe:
Based on measurement 200mbps down 100mbps up
0/ do waveform measurement
1/ set ingress limit to zero
2/ set egress limit to half of measured 100Mbps = 102400kbps = 51200
3/ measure waveform
4/ add half of the rest of bandwidth 76800 ... 89600 ... 96000 ... 99200
5/ when the additional upload latency starts to increase make one step back to the sweet spot.
6/ IF fownload added latency is still bad (you do not get at least A) repeat the procedure with download (102400 153600 179200 192000 198400 ...) now paying attention to download latency
7/ Post first and last measurement just to confirm it worked. You have to redo measurement whenever provider improves access speed, because these are hard limiters.

i.e your problem with sluggish internet is not absolute speed (200Mbps means 2x 8k TV) but absolute latency.

Thank you, after following your settings, the wifi download speed of 1G uses less than 7% of the CPU.

Wait a second - you measured 200/100, not 1000/1000, take a precise measurements and implement one of queue managers. Even when it is 100/100 you can have most of realtime calls and gaming all at once while kids watch TV.
For WED - let it run for a week, it is unstable on some platforms.

Okay, thank you for the reminder

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.