TL-WR842ND Change transmission power

#1

TP-Link TL-WR842ND Change transmission power

Hello,
I would like to take my old TP-Link WR842ND router with me to the USA (vacation). There a transmission power of 1000 mWatt may be used. How can I set this in my TP-Link?

I can't find the settings recommended here.

Die Sendeleistungserhöhung ist dann ein ganz einfacher Handgriff. Man trägt in die Konfigurationsdatei “/etc/config/wireless ” im Bereich “ config wifi-device radio0 ” die Zeile “ option country US ” ein und startet den Router neu. Danach wird man feststellen, dass mit dem Befehl “ iwconfig ” der Wert “ Tx-Powervon 20 auf 27 dBm erhöht wurde.

#2

This should help


https://www.rapidtables.com/convert/power/mW_to_dBm.html

From that, you are looking at 30dBm maximum alowed by the regulations. The maximum possible will depend on your hardware, but as long as you pick the correct region in Advanced Settings in LuCI, the options available to you should comply with the regulations.

Note that increasing the power isn't always good; sometimes it affects the signal quality (and the hardware lifetime), plus of course other concerns such as health factors and extending the coverage of your network outside your house, allowing others to see it.

#3

but as long as you pick the correct region in Advanced Settings in LuCI, the options available to you should comply with the regulations.

Thanks for the quick answer.

Is it possible that the LuCl is not installed?
I only have 3 Mb space left.

Is there another way to increase the transmission power?

Thank you för Yours help

#4

In the wifi-device section of /etc/config/wireless, make sure to have option country 'US' and option txpower '27'. For best results, always set option country to whatever country you are in. Leaving it unset results in the lowest possible settings, those that would be legal in any country, since the driver does not know which country to use.

An actual transmit power of 30 dBm (or even 27) is not possible with that model, it does not have the hardware needed. The command iwinfo wlan0 txpower will show possible settings.

#5

From my Archer C7, maximum power for US, see the last two lines of my /etc/config/wireless. You will need to add that to the radio you are using.

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0'
	option legacy_rates '0'
	option channel '40'
	option htmode 'HT20'
	option country 'US'
	option txpower '23'
#6

Thanks for the helpful answers.
I managed to change OpenWRT to German.

Only I can't find the area
etc/config/wirelesss.

etc/, but I don't find the rest.
How can I access it?

I have now connected a network cable and
can access the router with 192.168.1.1.
I get the welcome page OpenWrt.

How do I get to the above path?
Do I need a specific program to do this?

I have Linux and Win7

Ich bin ganz stolz, habe es geschafft OpenWrt auf Deutsch umzustellen.

Nur, ich finden den oben genannten Link nicht.

Wie komme ich auf den Link? Habe ein Netzwerkkabel angeschlossen, komme auf die Startseite.

Doch wie komme ich auf Dateistrucktur?

#7

On Linux you should have SSH out of the box. On Windows you will use PuTTy for that.

If you are not much into command line thing, you can use WinSCP for Windows. It's free to download and making editing files very easy.

Having said that, it's not recommended to edit config files manually unless you know what you are doing. It can be an easy way to break things up.

1 Like
#8
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option htmode 'HT20'
	option disabled '0'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
        option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface
	option network 'wwan'
	option ssid 'JoachimHeller@web.de 2.4oben'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid '7C:FF:4D:D1:AF:77'
	option key 'sdsddsds'
#9

First of all, thanks for the help.

I fought my way through. Everything changed to German.
How can I now change the transmission power,
without overloading the old TP-Link WR-842 ND.

What do I have to change to get the optimal performance for America?
to hire?

#10

If you need to adjust the power, you can include it similar to my example, but with the correct country code.

There is no "optimal performance" for specific region. Countries set maximum transmit power for devices to adhere to local health guidlines, and that should be the maximum you are allowed to use from a legal point of view. It doesn't mean it's good for your particular setup. Increase the power comes at the cost of increasing noise and shortening hardware life time due to increased heat (plus other factors such as making your devices think the router is close by and prefer it over other APs that might actually be in better position if you have multiple APs, and also making your network visible to more outside people.

So if hardware default isn't give you the signal you desire, you could start increasing the power gradually until you get the signal strength you need.

#11

I would like to adjust the transmission power for the USA. 1W is allowed, 100mW in Germany. There is no point in increasing the power in Germany, because the remote station only has 100mW.

In addition I do not want to become delinquent.
1W does not reach the old box anyway.
Maybe a little more.

Can someone tell me what I have to adjust where.
I posted the values.

#12

If you select the correct country code, tx power is limited to the allowed levels - which can be further reduced for most chipsets (not mwlwifi though).

That said, consumer devices are very unlikely to reach 1 watts tx power under any circumstances.

#13
  • Go to /etc/config/wirless
  • At the end of section config wifi-device 'radio0' Add the following: option country 'US'
  • Run the following command: iw phy0 info
  • Note the dBm value
  • At the end of section config wifi-device 'radio0' Add the following: option txpower '23' (replace 23 with the actual value you received.

You could possibly do it lot easier with ucicommands, but I don't know which commands you can use to change the region for the phy, as iw reg set US seems to does it for the global only but doesn't affect the individual phys

#14

It goes without saying that you would need to commit the changes after each editing of the config files to take effect, or just restart the router.

1 Like
#15

Thanks for the help.
Learned a lot.

Is there a way to increase the number of channels?

#16

What does this mean...to get 400 WiFi channels...or to use more bandwidth?

Not sure what you're asking for here.

(If you're referring to channels 12, 13 and 14; and you cannot see them with the properly configured country setting, then they are illegal for use in your nation.)

1 Like
#17

To clarify, 2.4 GHz channels 12 and 13 are legal in Europe but not the US.

Having said that, it's almost always best to stick to the non-overlapping channels 1, 6 or 11.

#18

Not in the US since December 23, 2016.

1 Like
#19

To be clear, I don't want more channels than allowed in America. But I ask myself the question can the channels simply be changed (adapted)? At home I can easily undo it. Then I'm in the legal area in both countries. That's the goal. If I buy a router there, I can no longer use it in Europe.

#20

The frequencies are standard and region-independent. It's just that some regions prohibit or strict the use of certain frequencies or bandwidth. There is more details about that for the 5 GHz band than the 2.4 GHz. But if you buy a device form the US it should work fine in Europe or anywhere else, provided you set the region correctly to make sure that the router complies to the local regulations.

you don't change your phone or laptop when you visit or transit in another country!

More about frequencies

1 Like