TL-WR841N v13 WiFi not stable?

#184

Hi,

Drivers updated yesterday.
Uploading a new build now...

https://my.pcloud.com/publink/show?code=kZXz3T7Zhr7RvDQxnw8YGb6DOA9xdRwVwPbk

Juliano

#185

Will try again new driver. 20190301 version still disconects clients...

Question: How can I install stock fw again? Tried to install with tftp TL-WR841Nv13_ES_0.9.1_4.16_up_boot[180524-rel55361].bin which shouold be right version but V13 blinks all leds in a endless loop. Installing OpenWRT with tftp again works...
Any idea?

#186

@tkmbe

Revert to stock:

http://wrt.raxp.ru/stock/wr841n-v13-stock.bin

Flash with tftp, rename to tp_recovery.bin .

Juliano

#187

Yes this version works! Thanks a lot!

One more question: I always compile my own OpenWRT Version with iptraf, password enabled etc.
in case of a reset I will not loose everything.
I guess you copy driver stuff in some place to compile. Were can I get the newest driver version and were should I put it to compile by myself, my openwrt version?

#188

@tkmbe

See post #121

Juliano

#189

Hello everyone, I installed the latest compilation on 03/17/2019. The wifi seems to be stable, I did not have disconnections nor wait times exhausted when loading a web page. I'm using it as a router. The driver has improved a lot since the last time I tried it a few months ago. I think that I will no longer install the stock firmware, also in stock tplink firmware, the wifi network disappeared after a few hours or until completing 1 day.

What I do miss and I am trying to configure is to limit the bandwidth to the wifi network of guests, using multi SSID for my main network and the guest network with OpenWrt in this 840n v4.

The new compilations are appreciated.

#190

Hi.

There was an update in Openwrt and drivers this day and i consider important...

New build uploaded.
Juliano

#191

Will try new version Thanks
It seems that version 20190301 was more stable than 20190316 about disconnection clients...

One more questions about compiling my own version.
Does the driver compile with "old OpenWRT versions" or do you update everytime the whole repository?
I have currently 18.06.1-r2-w-r7258-5eb055306f version and want to try compile newest driver with this version....
My Makefile of mt76 looks the following by default (post #121):

PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
PKG_SOURCE_DATE:=2019-01-25
PKG_SOURCE_VERSION:=0b939dc7edf0629ee2d1475b6dd6b9a4a1f9384d
PKG_MIRROR_HASH:=64279b0186a6dabd8916085e6bb272b11a1a8c3f2ad4e41c9fb1cefef71d71ba

If tried to do a git pull in package/kernel/mt76 but fails with the following

remote: Enumerating objects: 6423, done.
remote: Counting objects: 100% (6183/6183), done.
remote: Compressing objects: 100% (2080/2080), done.
remote: Total 4804 (delta 3222), reused 3872 (delta 2404)
Receiving objects: 100% (4804/4804), 2.10 MiB | 1.21 MiB/s, done.
Resolving deltas: 100% (3222/3222), completed with 549 local objects.
From https://git.openwrt.org/openwrt/openwrt
   f3f21b3d2a..981f5f7e40  lede-17.01    -> origin/lede-17.01
   0c24b363a6..bfdf00977d  master        -> origin/master
   19a6c4b2b3..6c3ca1d1ea  openwrt-18.06 -> origin/openwrt-18.06
You are not currently on a branch.
Please specify which branch you want to merge with.
See git-pull(1) for details.

    git pull <remote> <branch>

Will this update the whole OpenWRT if it works with a or will it get only mt76 updates?

#192

Julian Build_20190323 does not install on my 841n v13.0 nor sysupgrade nor tftp install.
Endless loop of all leds blinking. Did you try to install?

#193

@tkmbe

Yep, i always test my builds before upload...
Anyway, Felix and mt76 developers made importants updates since this day...
It is on my my pCloud , as always...

Juliano

#194

My question is because I have downloaded and installed your lateste version on V13.0 of your Build_20190323 and does break the device...

#195

Julian one more question. Which is the right way to contact Felix? I cannot find to contact him about an problem.
The mac80211.c has now an implicit declaration of function 'ieee80211_schedule_txq and therefore won't compile on my sistem at least because all warnings are treated as errors (OpenWRT default?)
Neverthelss this function should be declared I think.

#196

@tkmbe

Open a new issue on mt76 Github.

Felix is @nbd168.

Juliano

#197

Thank you for compiling it again. I have been using Build_20190328_Driver20190327 from last 2 days and seems to be stable.
I will keep you posted about the issues if I face again.

Thanks again for taking your time for this project :slight_smile:
Santosh

#198

Here is my update: I am using it from last 2 weeks as a main router and its seems to be pretty good in terms of stability, but intermittently I still see packet drops for 4-5 packets and it will recover on its own. I don't know if my ISP has issues or there is incorrect config.

#199

@Santosh

A new driver update will be comming in the next days, so, let´s wait.

I will keep the post and the builds updated.

Regards,
Juliano

1 Like
#200

Hello @Santosh

I uploaded a new build now...
Please try and see if it´s works better to you.

Do not preserve settings while update, this driver has a lot of changes and fixes.

https://my.pcloud.com/publink/show?code=kZXz3T7Zhr7RvDQxnw8YGb6DOA9xdRwVwPbk

Regards,
Juliano

#201

Thanks again for putting together the latest driver/fixes.

I have flashed it today and till now everything looks good except changing SSID name/password is failing to commit so I selected Apply Anyway which worked (even performed factory reset with same failure).

I will keep you posted about its usage.

Thank you,
Santosh

#202

@julianocs
Based on 2 days testing: Not much difference in stability, as I could still see packet loss from interface (laptop not from inside openwrt) as you can see below

--- google.com ping statistics ---
236 packets transmitted, 213 packets received, 9.7% packet loss
round-trip min/avg/max/stddev = 63.147/138.593/753.376/60.842 ms
#203

@Santosh

Thanks for the feedback.
Developers are still working on the driver, it´is not officially released yet.
Anyway, i made a new build now, there are some fixes from previous version.

https://my.pcloud.com/publink/show?code=kZXz3T7Zhr7RvDQxnw8YGb6DOA9xdRwVwPbk

Juliano

1 Like