TL-WR840N v5 bootloop

Hello, i have just flashed my TL-WR840N V5 and already can access the internet, but somehow i just clicking update with Stock Firmware, and i finally brick it. now my router light is blinking try to installed via TFTP and not working its fully download firmware but after flash its starts blinking again is there any other ways to bring back my router without soldering ?

Hi. What sort of firmware are you using for TFTP recovery?

1 Like

i use this bin openwrt-18.06.2-ramips-mt76x8-tl-wr840n-v5-squashfs-sysupgrade
for recovery
i found router ip adress
and getway
and tftp file request name is tp_recovery.bin
i found avove info via were shark tool
after that i tried to flash oem downloaded from tp link official server
its still blinking

I think you have to use "stripped" original firmware for recovery. Strip boot part on linux machine:
dd if=original.bin of=striped.bin skip=257 bs=512

Rename stripped.bin to tp_recovery.bin for TFTp recovery.

Did it for you:

i flashed it but didnt work its still blinking you can se my full details in this post

Did you try file in my link? You have to wait for some time after flashing. Leave for at least 5 minutes and let us know how it goes.

1 Like

after 5 min i will reply

i waited but no result light is still blinking
this is gpl for my router
can i flash bootloader for my router

Do you even have any knowledge what bootloader or GPL is? And, please, stop creating multiple threads


Hi guys, I have the same problem with my router. I tried to flash the firmware with the boot part cropped, but I also get a bootloop. How I can to fix this problem? Link for my file without a boot part: file

Problem solved. Could return the stock firmware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.