TL-WR840N v4 / wifi channel=auto does not work

Hi

I'm using the latest snapshot for TL-WR840N v4. Everything works OK, except when I set the wifi channel to auto. It seems to disable the wireless interface and no sta/client can discover the AP/master on a survey.

If I set a fixed channel (from 1 to 11) it works normally.

Does anyone know of a workaround to make channel=auto work?

This sounds like a bug. Consider filing an issue here:

https://bugs.lede-project.org/

Surprised that wifi is working well for you - wireless support is for the birds in 840Nv4. Dont you get random disconnects at every turn? Are you using wpa2?

Using wpa2.

I don't get wifi disconnections, but throughput performance is not great. I can get ~15mbps on wifi.

psk2+aes or psk2+ccmp, what txpower? Could you post your /etc/config/wireless (delete mac address if youre paranoid haha)

Here is mine by the way

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk2+aes'
option key 'BLUEISTHECOLOR123'
option ssid 'MisHuevosEnTuJeta'
option disassoc_low_ack '0'
option max_inactivity '86401'
option skip_inactivity_poll '1'
option wpa_group_rekey '0'