TL-WR840 V5 help

I installed lede snapshot on my tplink wr840n v5 eu.
And then tried to revert back ti official firmware by putting firmware file in tmp folder and using command but it gave error about erasing block.
After that somehow the power was cut and now my router is not showing any connection and it's led is blinking with very slow speed about 3 seconds.
Now what should I do to bring my router back to life.

TFTP flash it with stock firmware.

Stock firmware files need to be trimmed before flashing them through OpenWrt. Otherwise it will brick.

Follow this tutorial on the TP-Link forum...

http://forum.tp-link.com/showthread.php?81462-How-to-recovery-the-router-when-you-bricked-it1

Rename the stock firmware file wr840v5_tp_recovery.bin

still no luck on wifi.....

Ok now it is working

are you sure wifi is working

I think the OP means the router is unbricked, since that was the topic of the thread...

Wifi is working and router is also unbricked

My is working but it is only snapshot.
Do you have luci or any GUI for it

my bad sorry , i was hoping there would be a fix soon