TL-WR1043ND v3 upgrade to 23.05.3 is same as 23.05

TP-Link TL-WR1043ND v3
I used this file for the upgrade "openwrt-23.05.3-ath79-generic-tplink_tl-wr1043nd-v3-squashfs-sysupgrade.bin"

yet the version remains at "OpenWrt 23.05.0 r23497-6637af95aa / LuCI openwrt-23.05 branch git-24.073.29889-cd7e519"

I did it twice to make sure .

I noticed the file size of 23.05.0 and 23.05.3 are the same .

Is this by design ?

Did you compare them ?

Binary, or by CRC ?

The md5sums are different but the byte count is the same - 6029646

So they're not the same then, except for the size.

Where/how did you DL the sysupgrade file ?

https://downloads.openwrt.org/releases/23.05.3/targets/ath79/generic/openwrt-23.05.3-ath79-generic-tplink_tl-wr1043nd-v3-squashfs-sysupgrade.bin

If the sysupgrade failed, before actually writing to flash (e.g. because of the uploaded image being deemed corrupt or because RAM has run out, which shouldn't be an issue with 64 MB RAM, but...), the router will just reboot without actually flashing anything.

My first approach, before actually debugging anything, would be:

  • check the download (correct sysupgrade image, sha256 checksum)
  • upload via scp to /tmp/ of the router
  • check the checksum again, sha256sum /tmp/openwrt*sysupgrade.bin
  • wifi down (this saves some RAM)
  • sysupgrade -v /tmp/openwrt*sysupgrade.bin

sha256sum OK

sysupgrade from the cli shows no errors (other than Commencing upgrade. Closing all shell sessions.)

version remains at 23.05.0

tried 23.05.1 with same result . wtf

you can always try to flash the factory image again, via TFTP.

https://openwrt.org/toh/tp-link/tl-wr1043nd#firmware_flashing

1 Like

You won't see the full sysupgrade output. Sysupgrade will close any pending SSH sessions and switch to a ramdisk e.g. before actually performing the upgrade. At that point, only a serial connection will show you what's breaking.

I reset to openwrt defaults
It then shows 23.05.3
I reload my backup
It then show 23.05.0 :crazy_face:

Because you're overwriting the file containing that info :wink:.

well I guess thats true but it still doesnt explain why the version is shows up incorrectly in LUCI .
So I upgraded again and found that the version info is correct in

/etc/os-release
VERSION="23.05.3"
PRETTY_NAME="OpenWrt 23.05.3"
VERSION_ID="23.05.3"
OPENWRT_RELEASE="OpenWrt 23.05.3 r23809-234f1a2efa"

which is different from

/etc/openwrt_release
DISTRIB_RELEASE='23.05.0'
DISTRIB_DESCRIPTION='OpenWrt 23.05.0 r23497-6637af95aa'

and

/etc/banner
OpenWrt 23.05.0, r23497-6637af95aa