TL-WR1043ND v2 fastpath NAT speed inconsistent

Hello! Recently I changed my ISP and now I have 500mbps/50mbps offer. Flashed my TL-WR1043ND v2 with OpenWRT and enabled software fastpath.

On ookla speedtest I'm always getting about 480-610mbps. When downloading games from Uplay/Steam, I noticed my download speed being inconsistent (between 40MB/s and 57MB/s, sometimes even dropping to 30MB/s for a couple of seconds).

I didn't know whether this was caused by my router, ISP, or steam servers, so I decided to investigate the issue. I installed htop on my router and started a speedtest.

During the speedtest router CPU was maxed out at 98,5-100%. At first my download speed went to about 570mbps, and then about halfway through the download test it started to drop to 490-500mbps

When downloading a game from steam/uplay, router CPU usage is about 80-90%, but it rarely gets to 100%

So I installed jperf on my laptop and PC, connected laptop to the WAN port and PC to one of LAN ports, and conducted some tests. Testing time set to 1 minute, update intervals to 1 second. The speed was usually about 790-820mbps, but quite a few times there was a single second when the speed was about 400mbps.

My whole network uses cat 6 cables, every NIC is capable of transmitting 1Gb/s.

My questions are:

  1. How likely is it that the router is at fault and how "normal" is it to get varying download speeds on services like steam etc.?
  2. Why are there some seconds during jperf test when the speed drops to 400mbps?
  3. To utilize my full connection speed, maybe it is time to finally buy a new router? Should TL-WR1043ND v2 be generally capable of handling that speed on software fastpath?

Thanks in advance for any responses!

Yes.
But anything beyond ~200-300 MBit/s needs a little attention before buying, as by far not all devices can achieve this.

No.
Fast-path and similar approaches are just trying to cheat, heuristically collating flows and handling them outside the normal netfilter (slow-) code paths. It can alleviate the load a bit, but you still need the power to really cope with these line-speeds - and the aging tl-wr1043nd is far below the requirements for that.

Do you have compared your test results with a pc conected directly to your modem?
Shared mediums like cable tend to give you varying results anyway...

have you tried to see if it is related to bufferbloat and try using SQM on it?

I am currently looking for some cheap router that can handle ~600Mbps speeds. In my area I can buy one of those routers:

  • MikroTik RB2011UiAS-2HnD-IN (quite old and budget device, I don't really believe it's gonna work much better than my current Tplink, but maybe someone has different experiences?)
  • MikroTik RB951G-2HnD - same as above, but maybe also worth trying?
  • MikroTik hAP acĀ² RBD52G - this one looks actually promising (looking at the test results provided at manufacturer's website)

Can you help me with picking a good new router with fast NAT speeds? :smiley:

That's actually a good point. Unfortunately though, the ethernet port latch in my laptop broke today. I'll probably get that glued back together tommorow/the day after, so I'll test that ASAP.

I haven't tried that. AFAIK, Fast Path is not compatible with SQM, so I didnt' install it. I'm not experiencing any latency issues, as every speedtest/ping reports 2ms to my ISP's server 50km away.
Should I try it anyway? If yes, is there any special way I should configure it or just install the package?