TL-WR1043nd v2 and PPPoE not working

Hello, I'm a software developer but my knowlege in networks is very very low.
I'm trying to configure a router (TP-LINK TL-WR1043nd v2) to my ONT. I have antoher router (TP-LINK TL-WR850N) that is fully working but I can't configure the other one. The configuration of the 850 is the following one

And the 1043 one is as follows:

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd45:f676:7437::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1.1'
        option proto 'pppoe'
        option username '************'
        option password '***********'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

but I alway get the error: Timeout waiting for PADO packets

daemon.warn pppd[9702]: Timeout waiting for PADO packets
daemon.err pppd[9702]: Unable to complete PPPoE Discovery
daemon.info pppd[9702]: Exit.
daemon.notice netifd: Interface 'wan' is now down
daemon.notice netifd: Interface 'wan' is setting up now
daemon.info pppd[9829]: Plugin pppoe.so loaded.
daemon.info pppd[9829]: PPPoE plugin from pppd 2.4.9
daemon.notice pppd[9829]: pppd 2.4.9 started by root, uid 0
daemon.warn odhcpd[1615]: No default route present, overriding ra_lifetime!

Can anyone help with it, please?

No expert, but I don't see any VLAN 100 in the Openwrt config.

1 Like

You are using eth1.1 for both wan and lan.

Modify these (:point_up_2:) sections to:

config interface 'wan'
        option device 'eth0.100'
        option proto 'pppoe'
        option username '************'
        option password '***********'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth0.100'
        option proto 'dhcpv6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
	    option vid '100'
        option ports '5t 6t'

If it still doesn't work, clone the wan MAC address of the 850 to the 1043.

2 Likes

Thank you so much, now it's working

1 Like