TL-WR1043ND v1 (request timed out for LuCI and SSH) & v2 (bootloop) softbrick, TFTP doesn't fix anything (v2)

Hi, I have two TL-WR1043ND, one is V1.8, second is V2.1. Both are flashed using this and this over the stock firmware's webgui update interface. Both devices had no problems before.

The V1.8 device seems to be behaving normally, but LuCi and SSH timed out, the lights flashes normally as it should be, with erratic router fuctionality (I can access Internet, but not for every boot), the device doesn't respond to any TFTP server on, nor Wireshark shows interesting ARP activity over Ethernet. Might need to find a better paperclip to initiate TFTP restore.

The V2.1 device is less fortunate. Upon flashing, the device is in constant LED bootloop pattern. Build in TFTP of the factory image, both trimmed (first) and untrimmed (second) doesn't work at all on fixing the bootloop.

How should I proceed?

Serial console would probably be a good idea

Already soldered header to V2.1, I don't quite understand how to issue commands with tftpd64

If you have functional serial, but TFTP doesn't really work, you can use kermit to transfer files and boot e.g. an initramfs (19.07 has those for both your models). I'd try on the v2 first (both your devices might have different issues of course).

Kermit is relatively slow, but at least it works if you cannot get a network connection going from the bootloader.

The V2 behaves like this from this point onwards since connected to serial:
Yes, I am running the V2 and V1 with equal wiring
Yes, I am running on TTL 3.3V and there's jumper on the adaptor to do so.

Condition: Power, then most light, then all lights, then power. The LAN reacts to data from the computer, but that's all, no ARP from the V2.

If this is a brick, then please let me know which components to procure.

The size parameter in terminal commands are in bytes encoded in hex, correct?

Yes I believe so. You mean for the memory address to load from?

No the firmware size parameter. Which flavor of Kermit runs on Windows 10?

Here's log from v1.8:

First hit on DuckDuckGo:

Doesn't support 115200 baud, nor probably the commands in c-kermit
If you can do it, please compile this for me:

EDIT: I managed to resurrect the V1.8 device to stock firmware Build 140319, not the V2.1 device. Yes I managed to build the binary, but not the Kermit 95 (k95g.exe) part of the artifact. Not important, since I managed to build C-Kermit.
Will share artifact tomorrow, or never.

@frollic can you help with the V2.1 situation?
UPDATE: V2.1 returned its bootloop LED pattern, means TFTP is working, and possibly serial. I'm trying to grab serial log of what happened. If I had to guess, something was wrong like some leftover electricity causing issue, or my subpar soldering iron making issues (thankfully, didn't kill the board, I really need to get some proper flux and real soldering iron)

UPDATE 2: As soon as serial is connected.. V2.1 went into comatose. Yeah. Gotta wait the cooldown then.

Apparently Build 140319 for V1.8 allows for TFTP, which I used to install this and there's no problem with it.

TFTP doesn't work, and serial is garbled with some snippets of normal text with the characteristic of this
Trying ground on USB port doesn't help either,

Also, here's C-Kermit I compiled,
most compiler I tried throws the error:

NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\VC\Tools\MSVC\14.28.29333\bin\HostX86\x86\cl.EXE"' : return code '0x2'
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\VC\Tools\MSVC\14.28.29333\bin\HostX86\x86\nmake.exe"' : return code '0x2'

Even vcvars32.bat or vcvars64.bat is executed.

So, TFTP doesn't work, and C-Kermit obviously doesn't work. What else that I can do? Do I need to grab an spi programmer?

Wrong voltage level (3.3V based usb2serial adapter needed, don't connect Vcc)?

V1.8 worked with the exact same setup, never connected VCC, 3.3V selected on adapter via jumpers.

Most Kermit version will probably have issues with the serial ports.
It's not designed for USB adapters, and will probably not detect them
because it's (Kermit) not using the proper Windows APIs.

I'd proabably switch to a Linux live environment, and take if from there.

Nope, I'm meant output from PuTTY (forgot to mention). V1.8 worked with C-Kermit I compiled above

Anyone has a better solution here?