TL-WR1043N/ND v1 Wifi keeps going down

I have had my TP-Link TL-WR1043N/ND v1 for a few years, and it's always worked fine until recently. The past few weeks, the wi-fi stops working intermittently. Either my phone or laptop can't find the network, or it disconnects and reconnects, or it appears to be connected but wont rx data.

The temporary solution is simple enough: ssh into the router, send the 'wifi off' command, then 'wifi on'. This will usually fix it at least for the rest of the day. But if someone can help me figure out where to start, I'd like to troubleshoot and remedy the problem permanently. Thanks.

BTW I'm running LEDE.

Mmmh, I guess updating to something more recent might be a good idea (but due to this being a 8/32 MB router also a bit tricky). But independent of that, if you truly did not change anything with the router or the client's software, you might just witness degrading hardware on the router?

1 Like

It's true, it might just be time for a new router. I don't see anything in the system logs that indicate a problem.

I'm pretty close to the newest release of LEDE, before the project merged back into OpenWRT. What do you think is the newest version of OpenWRT my router can handle? The OpenWRT site seems to recommend 19.07.2, and I'm assuming I could just use the upgrade firmware since I'm already basically running OpenWRT. Does that sound right?

Finally, this hardware does have its own usb slot for network-attached storage. Maybe there's a way to put a thumb drive in it and use it as virtual RAM? I've never heard of anyone doing that, but I thought I'd throw that out there.

I am always for trying to not trash electronics prematurely, so certainly worth spending some time to see whether its fixable, just with the dscription, no substantial changes, but degrading performance things look a bet bleak (but then maybe the RF surround has changed and there are other APs doing unexpected things in your vicinity?)

That was before the OpenWrt 18 was released then? I assume that it is high time to update for security fixes alone.

No direct experience with this device, but I believe the TOH is kept pretty up to date, so if that says 19.07.2 is fine, I would certainly try that.

You could try the extroot approach if the 8 MB flash size stsarts to get tight, and/or a swap partition to extend the memory a bit. But please be aware that USB fash is multiple orders of magnitude slower than RAM, so if you need swap/paging space to run some software your router is going to feel like you submersed it in molasses... (also not all memory allocations can be served by swap space, so even with a gigabyte of swap you still might encounter out-of-memory situations). In short swap is a reasonably way to make your router more resiliant against arbitrary reboots due to the OutOfMemory killer triggering an unscheduled reboot, and you might be able to run a few programs you could not otherwise, but please do not expect and substantial performance increases from adding swap space.
There is also compressed swap/compressed memory, which under normal conditions promises to actually give you a slight speed-up (but I never tested that myself, and I believe that there are corner cases where compressed swap/RAM performs worse than normal swap/RAM).

Good luck...

Thanks. And yes, OpenWRT will absolutely allow you to put a USB stick in your NAS port and use a partition on it as ram. Now if I can change swappiness just like I would any Linux OS, and I assume I can, then I'll just reduce the swappiness as much as possible and the system will only use this partition when it absolutely has to, preventing a reboot.

Now that my swap is in place, I'll try the upgrade and see if this helps.

OK, I don't want to derail my own topic here, but the firmware upgrade seems to have knocked out my wifi entirely. Now, the wireless page in Luci says this:

radio0 | Generic 802.11bg | Device is not active

disabled | SSID: LEDE | Mode: Master | Wireless is not associated

radio1 | Generic 802.11bgn | Device is not active

disabled | SSID: OpenWrt | Mode: Master | Wireless is disabled

Now, if I recall correctly, I already had the N wlan disabled and was only using the G network, named LEDE. But now, this isn't associated with anything and radio0 is not active.

I tried going into /etc/config/wireless and explicitly setting radio0 to option disabled '0'. This didn't change anything.

I saw some warnings online not to enable wifi over Luci after a firmware upgrade, but these warnings appear to be from over 6 years ago. At one point, Luci was saving these settings incorrectly. I don't know if that's relevant to this situation.

You apparently cross-graded from ar71xx to ath79, but kept your settings from ar71xx. This doesn't work, as especially the wireless configuration is different between the mach file based ar71xx and ath79 (and some other settings as well). Resetting your device to OpenWrt defaults (firstboot) should get you going again.

On the CLI you could do a few edits to /etc/config/wireless(*) and get wifi going again but with LuCI you should do what @slh said with a full reset.

There's not much reason to set the radio to g only. If you don't have any b clients there's a performance gain by turning off legacy rates (b modulations).

  • those edits would be to copy the "path" specification from the new radio1 section to replace the ar71xx style path on radio 0. Then delete radio1 since there is actually only one radio.
  • Some of the other options like legacy_rates 0 may not have existed in LEDE or had different names.

OK, I sshed in and ran fastboot, then rebooted, then set up my router again the way I like it. The wifi is working again, and it's only advertising one radio, which is b/g/n.

Everything is working fine for now. I'll see if my wifi performance is better. If so, this is a reminder to upgrade the firmware from time to time. Thanks to everyone for your help.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.