TL-WDR6500 no longer support?

Hello everyone, 3-yr-old openwrt user here. Using version 19.07.10 for my TL-WDR6500, recently I was tring to change the theme of luci to a dark one, but got errors after applying it:

/usr/lib/lua/luci/template.lua:97: Failed to execute template 'sysauth'.
A runtime error occurred: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'header'.
A runtime error occurred: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'themes/freifunk-generic/header'.
A runtime error occurred: [string "/usr/lib/lua/luci/view/themes/freifunk-gene..."]:20: attempt to call field 'node_childs' (a nil value)
stack traceback:
	[string "/usr/lib/lua/luci/view/themes/freifunk-gene..."]:20: in main chunk
stack traceback:
	[C]: in function 'error'
	/usr/lib/lua/luci/template.lua:97: in function 'render'
	/usr/lib/lua/luci/dispatcher.lua:755: in function 'include'
	[string "/usr/lib/lua/luci/view/header.htm"]:3: in main chunk
stack traceback:
	[C]: in function 'error'
	/usr/lib/lua/luci/template.lua:97: in function 'render'
	/usr/lib/lua/luci/dispatcher.lua:755: in function 'include'
	[string "/usr/lib/lua/luci/view/sysauth.htm"]:1: in main chunk
stack traceback:
	[C]: in function 'error'
	/usr/lib/lua/luci/template.lua:97: in function </usr/lib/lua/luci/template.lua:85>
	(tail call): ?
	(tail call): ?
	/usr/lib/lua/luci/dispatcher.lua:984: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:478: in function </usr/lib/lua/luci/dispatcher.lua:477>

Then I googled and was told version 19.07.10 was too old to be supported, while I didn't find any release newer than it for my device. I reset my router and tried the latest snapshot (nightly build) but luci did not work. I know ar71xx is deprecated while I'm not familiar with linux and I can't migrate it to ath79 myself. So will you support TL-WDR6500 again in the future? or any other solution for a dark theme on 19.07.10? thx

Best regards,

snapshots don't come with the webui.

use https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ath79%2Fgeneric&id=tplink_tl-wdr6500-v2 and add luci to the list of packages.

you could try to add the theme package to the list too, but the image might get too big, same could happen if you add luci.

sysupgrade via ssh using the generated sysupgrade image, and the webui should be back again.

WDR6500 only have 8mb flash, it'll be EOLed after the upcoming release (where it wouldn't have been available anyway).

1 Like

Thanks, no wonder I can't login to 192.168.1.1, only to get connection refused error, I just thought every factory and sysupgrade release contains luci and only kernel doesn't. Anyway, now I've got everything done and things worked quite well!

It's so sad to know my router EOLed.

WDR6500 only have 8mb flash

But WDR6500 has 128mb RAM, while I have another router Phicomm K2 (v22.4 or older), formerly called PSG1218 Ax, only with 8mb ROM and 64mb RAM and a worse CPU, I can still find it in every stable release (19.07.x-23.05.x). But WDR6500 stopped on 19.07.10, that's strange! I hope the upcoming stable release will add support to it, even if it's the last supported version.

different radios (and SoC), not requiring the ar71xx conversion you mentioned previously.

it probably won't, I checked the ath79 RC2 dir, it wasn't there.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.