TL-WA801ND v5 - Repeater + bridge

Setup:
Modem - in bridge mode
Router 1 - Mikrotik, using modem as wan-in and connecting via pppoe, emits wifi on 2 bands
Router 2 - TL-WA801ND v5 with this openWRT snapshot

Desired outcome:
R2 connected to R1 via wifi
R2 repeating the R1 network via wifi
R2 sharing the R1 network via its only eth port
R2 wifi should have the same SSID, security, etc as the R1 network
R1 should act as DHCP

Additional notes:
R1 doesn't have WDS. I'm having trouble setting it up properly... i know, i suck

The original firmware of the router had the option to repeat a wifi network so i guess it should be possible.

Is this outcome even possible? Maybe something close to the desired outcome?
Can someone instruct me on what i actually need or maybe even drop a few uci lines on how i would set it up?

I tried to do this numerous times by following various instructions on the wiki pages, but without success. I manage to create a wifi connection to R1 and get access to the internet, but bridging that to the eth port never works and i can't access the R1 network from that wired device. I also had no success creating a repeating network.

Thanks

you can with relayd

https://oldwiki.archive.openwrt.org/doc/recipes/relayclient

Thats exactly the page i was following when i tried to set up everything.
I did the SSH version and everything seemed to execute correctly, but alas i had no access to the network via eth and the repeater network showed no signs of life.

Could it be that Mikrotik (routeros) doesn't play well with openwrt?
I should probably try the same settings but with another base router (R1).
I mean, the reason i started all of this is because i had no luck setting up WDS on routerOS and a repeater with the stock firmware of this router.

Do you care if the R1 and R2 clients are on the same subnet or not?

1 Like

As long as devices see eachother i dont mind how many subnets there are.
A device on R2 should be able to access the internet, but also for eample a media center on the R1 network.

So i gave this another try and here is the status:

R2 is connected to R1 via wifi
R2 can ping R1
R2 has internet access
Device on eth port can't ping R1 (PING: transmit failed. General failure.)
Device on eth port has no internet access
Wifi devices can't connect to the repeating network on R2

I have yet to try this with a master router thats not a (badly configured) mikrotik.
I will report back.

If anyone else has ideas or is willing to take a look at my config files, i'll gladly share them.

Thanks

my config
*
WIRELESS

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option disabled '0'
	option legacy_rates '1'
	option country 'FR'
	option htmode 'HT20'
	option channel '3'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option legacy_rates '1'
	option disabled '0'
	option channel '3'
	option country 'FR'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk-mixed'
	option key '1234567890'
	option wpa_disable_eapol_key_retries '1'
	option ssid 'MT300N-V2-230'
	option disabled '1'

config wifi-iface
	option ssid 'Livebox-6256'
	option device 'radio1'
	option mode 'sta'
	option bssid '8C:F8:13:29:62:00'
	option encryption 'psk-mixed'
	option key '1234567890'
	option network 'wwan lan'
	option short_preamble '0'
	option disassoc_low_ack '0'

NETWORK

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd77:cf5e:22a3::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	option ifname 'eth0 eth0.1 eth0.2'
	option ipaddr '192.168.2.230'
	option dns '192.168.1.1 8.8.8.8'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'ca:d0:19:00:63:00'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'ca:d0:19:00:63:01'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config interface 'wwan'
	option proto 'static'
	option ipaddr '192.168.1.230'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '192.168.1.1 8.8.8.8'
	option broadcast '192.168.1.255'

config interface 'stabridge'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'

DHCP

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option ignore '1'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


FIREWALL

config defaults
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'REJECT'

config zone
 option name 'lan'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'ACCEPT'
 option network 'lan wwan'

config include
 option path '/etc/firewall.user'

config include 'miniupnpd'
 option type 'script'
 option path '/usr/share/miniupnpd/firewall.include'
 option family 'any'
 option reload '1'

1 Like