Tl-eap245 v3 dumb ap not working (atheros loops up and down)

Hi! I am trying to set up a TP-Link EAP245 v3 as a dumb-ap unsuccessfully.

I tested Openwrt

  • stable 21.02.3
  • OpenWrt 22.03.0-rc6 from 13ago2022

I already have a working TP-Link EAP225-wall v2 just working fine on the same network and have followed all steps from the Openwrt Wiki dumb-ap guide without any success.

I have a managed switch (Zyxel GS1900-8HP with Zyxel stock firmware) but have not configured any VLAN.

I will start by the configuration, and then with the log wich is showing an issue with Atheros going up and down constantly.

The configuration

/etc/rc.local

# these services do not run on dumb APs
for i in firewall dnsmasq odhcpd; do
    if /etc/init.d/"$i" enabled; then
        /etc/init.d/"$i" disable
	/etc/init.d/"$i" stop
    fi
done

if test -f /etc/config/firewall; then mv /etc/config/firewall /etc/config/firewall.unused; fi

exit 0

/etc/config/network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd52:47c5:3fde::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'eth0.1'
	list ports 'eth0.2'
	list ports 'eth0.3'
	option bridge_empty '1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.253'
	option gateway '192.168.2.254'
	option broadcast '192.168.2.255'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	list dns '192.168.2.240'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 2 5'

config device
	option name 'eth0'
	option ipv6 '0'

config device
	option name 'eth0.1'
	option type '8021q'
	option ifname 'eth0'
	option vid '1'
	option ipv6 '0'

/etc/config/wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option country 'AR'
	option cell_density '0'
	option htmode 'VHT40'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'AR'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'CoralRojo2_2G_eap245'
	option encryption 'psk2+ccmp'
	option key 'PASS'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'CoralRojo2_5G_eap245'
	option encryption 'psk2+ccmp'
	option key 'PASS'
	option network 'lan'

/etc/config/dhcp


config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'
	list ra_flags 'none'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

And the system log which shows the issue of the port loop going up and down "Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up". I had reduced the size of the log by removing a long extension of such loop and had to remove more content due to I exceed the post size:

Sun Aug 14 19:19:09 2022 kern.notice kernel: [    0.000000] Linux version 5.4.188 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16554-1d4dea6d4f)) #0 Sat Apr 16 12:59:34 2022
Sun Aug 14 19:19:09 2022 kern.info kernel: [    0.000000] printk: bootconsole [early0] enabled
Sun Aug 14 19:19:09 2022 kern.info kernel: [    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
Sun Aug 14 19:19:09 2022 kern.info kernel: [    0.000000] MIPS: machine is TP-Link EAP245 v3
Sun Aug 14 19:19:09 2022 kern.info kernel: [    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
Sun Aug 14 19:19:09 2022 kern.info kernel: [    0.000000] Initrd not found or empty - disabling initrd
Sun Aug 14 19:19:09 2022 kern.warn kernel: [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Sun Aug 14 19:19:09 2022 kern.warn kernel: [    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
...
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.113735] switch0: Atheros AR8337 rev. 2 switch registered on mdio.0
Sun Aug 14 19:19:09 2022 kern.notice kernel: [    1.159671] random: fast init done
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.692132] ag71xx 19000000.eth: connected to PHY at mdio.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.703401] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: sgmii
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.710134] i2c /dev entries driver
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.715786] NET: Registered protocol family 10
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.725414] Segment Routing with IPv6
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.729372] NET: Registered protocol family 17
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.734056] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.747447] 8021q: 802.1Q VLAN Support v1.8
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.752586] PCI host bridge /ahb/pcie-controller@18250000 ranges:
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.758951]  MEM 0x0000000012000000..0x0000000013ffffff
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.764357]   IO 0x0000000000000000..0x0000000000000000
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.769933] PCI host bridge to bus 0000:00
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.774210] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.781313] pci_bus 0000:00: root bus resource [io  0x0000]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.787074] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.794088] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.802308] pci 0000:00:00.0: [168c:0040] type 00 class 0x028000
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.808572] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.815721] pci 0000:00:00.0: PME# supported from D0 D3hot D3cold
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.822054] pci 0000:00:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5 GT/s x1 link)
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.837219] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.844098] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.852538] hctosys: unable to open rtc device (rtc0)
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.862243] VFS: Mounted root (squashfs filesystem) readonly on device 31:8.
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.876393] Freeing unused kernel memory: 1212K
Sun Aug 14 19:19:09 2022 kern.warn kernel: [    1.881095] This architecture does not have kernel memory protection.
Sun Aug 14 19:19:09 2022 kern.info kernel: [    1.887745] Run /sbin/init as init process
Sun Aug 14 19:19:09 2022 user.info kernel: [    2.554393] init: Console is alive
Sun Aug 14 19:19:09 2022 user.info kernel: [    2.558225] init: - watchdog -
Sun Aug 14 19:19:09 2022 user.info kernel: [    3.646453] kmodloader: loading kernel modules from /etc/modules-boot.d/*
Sun Aug 14 19:19:09 2022 user.info kernel: [    3.682511] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
Sun Aug 14 19:19:09 2022 user.info kernel: [    3.700804] init: - preinit -
Sun Aug 14 19:19:09 2022 kern.notice kernel: [    4.776842] random: jshn: uninitialized urandom read (4 bytes read)
Sun Aug 14 19:19:09 2022 kern.notice kernel: [    4.889991] random: jshn: uninitialized urandom read (4 bytes read)
Sun Aug 14 19:19:09 2022 kern.notice kernel: [    4.979015] random: jshn: uninitialized urandom read (4 bytes read)
Sun Aug 14 19:19:09 2022 kern.info kernel: [    5.987171] eth0: link up (1000Mbps/Full duplex)
Sun Aug 14 19:19:09 2022 kern.info kernel: [    5.995756] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Sun Aug 14 19:19:09 2022 kern.info kernel: [    6.013256] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Sun Aug 14 19:19:09 2022 kern.warn kernel: [    6.046266] urandom_read: 4 callbacks suppressed
Sun Aug 14 19:19:09 2022 kern.notice kernel: [    6.046273] random: procd: uninitialized urandom read (4 bytes read)
Sun Aug 14 19:19:09 2022 kern.info kernel: [    8.035902] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:19:09 2022 kern.info kernel: [    9.060027] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:19:09 2022 kern.notice kernel: [   10.285142] jffs2: notice: (565) jffs2_build_xattr_subsystem: complete building xattr subsystem, 15 of xdatum (11 unchecked, 3 orphan) and 18 of xref (3 dead, 0 orphan) found.
Sun Aug 14 19:19:09 2022 user.info kernel: [   10.303159] mount_root: switching to jffs2 overlay
Sun Aug 14 19:19:09 2022 kern.warn kernel: [   10.311762] overlayfs: upper fs does not support tmpfile.
Sun Aug 14 19:19:09 2022 user.warn kernel: [   10.322241] urandom-seed: Seeding with /etc/urandom.seed
Sun Aug 14 19:19:09 2022 kern.info kernel: [   10.442910] eth0: link down
Sun Aug 14 19:19:09 2022 user.info kernel: [   10.463965] procd: - early -
Sun Aug 14 19:19:09 2022 user.info kernel: [   10.467027] procd: - watchdog -
Sun Aug 14 19:19:09 2022 user.info kernel: [   11.102017] procd: - watchdog -
Sun Aug 14 19:19:09 2022 user.info kernel: [   11.106626] procd: - ubus -
Sun Aug 14 19:19:09 2022 kern.notice kernel: [   11.176067] random: ubusd: uninitialized urandom read (4 bytes read)
Sun Aug 14 19:19:09 2022 kern.notice kernel: [   11.184820] random: ubusd: uninitialized urandom read (4 bytes read)
Sun Aug 14 19:19:09 2022 user.info kernel: [   11.196463] procd: - init -
Sun Aug 14 19:19:09 2022 user.info kernel: [   12.019936] kmodloader: loading kernel modules from /etc/modules.d/*
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.090150] Loading modules backported from Linux version v5.10.110-0-g3238bffaf992
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.098108] Backport generated by backports.git v5.10.110-1-0-g1fbde860
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.159308] xt_time: kernel timezone is -0000
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.330147] PPP generic driver version 2.4.2
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.344432] NET: Registered protocol family 24
Sun Aug 14 19:19:09 2022 user.info kernel: [   12.375031] urngd: v1.0.2 started.
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.428093] ath10k 5.10 driver, optimized for CT firmware, probing pci device: 0x40.
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.452539] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
Sun Aug 14 19:19:09 2022 kern.info kernel: [   12.459308] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
Sun Aug 14 19:19:09 2022 kern.notice kernel: [   12.551011] crng init done
Sun Aug 14 19:19:09 2022 kern.info kernel: [   15.084137] ath10k_pci 0000:00:00.0: qca99x0 hw2.0 target 0x01000000 chip_id 0x003b01ff sub 168c:0002
Sun Aug 14 19:19:09 2022 kern.info kernel: [   15.093704] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Sun Aug 14 19:19:09 2022 kern.info kernel: [   15.112565] ath10k_pci 0000:00:00.0: firmware ver 10.4b-ct-9980-fW-13-5ae337bb1 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 b36a12bf
Sun Aug 14 19:19:09 2022 kern.info kernel: [   15.201987] ath10k_pci 0000:00:00.0: board_file api 2 bmi_id 1:1 crc32 08fa09f2
Sun Aug 14 19:19:09 2022 kern.warn kernel: [   16.360481] ath10k_pci 0000:00:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Sun Aug 14 19:19:09 2022 kern.warn kernel: [   16.368252] ath10k_pci 0000:00:00.0: msdu-desc: 2500  skid: 32
Sun Aug 14 19:19:09 2022 kern.info kernel: [   16.444179] ath10k_pci 0000:00:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Sun Aug 14 19:19:09 2022 kern.info kernel: [   16.455500] ath10k_pci 0000:00:00.0: wmi print 'free: 31080 iram: 23028 sram: 9596'
Sun Aug 14 19:19:09 2022 kern.info kernel: [   16.720703] ath10k_pci 0000:00:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 32 raw 0 hwcrypto 1
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.804875] ath: EEPROM regdomain: 0x0
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.804881] ath: EEPROM indicates default country code should be used
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.804884] ath: doing EEPROM country->regdmn map search
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.804897] ath: country maps to regdmn code: 0x3a
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.804901] ath: Country alpha2 being used: US
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.804904] ath: Regpair used: 0x3a
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.886492] ath: EEPROM regdomain: 0x0
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.886499] ath: EEPROM indicates default country code should be used
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.886501] ath: doing EEPROM country->regdmn map search
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.886514] ath: country maps to regdmn code: 0x3a
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.886518] ath: Country alpha2 being used: US
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.886521] ath: Regpair used: 0x3a
Sun Aug 14 19:19:09 2022 kern.debug kernel: [   16.898305] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Sun Aug 14 19:19:09 2022 kern.info kernel: [   16.900294] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
Sun Aug 14 19:19:09 2022 user.info kernel: [   16.935981] kmodloader: done loading kernel modules from /etc/modules.d/*
Sun Aug 14 19:19:10 2022 authpriv.info dropbear[1198]: Not backgrounding
Sun Aug 14 19:19:12 2022 daemon.notice wpa_supplicant[1271]: Successfully initialized wpa_supplicant
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: bonding
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: 8021ad
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: 8021q
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: macvlan
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: veth
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: bridge
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: Network device
Sun Aug 14 19:19:13 2022 user.notice : Added device handler type: tunnel
Sun Aug 14 19:19:15 2022 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/dhcp
Sun Aug 14 19:19:15 2022 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network
Sun Aug 14 19:19:15 2022 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/luci-splash
Sun Aug 14 19:19:15 2022 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/qos
Sun Aug 14 19:19:15 2022 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/miniupnpd
Sun Aug 14 19:19:15 2022 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/odhcpd
Sun Aug 14 19:19:16 2022 user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
Sun Aug 14 19:19:16 2022 user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
Sun Aug 14 19:19:16 2022 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/luci_statistics
Sun Aug 14 19:19:16 2022 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/dhcp
Sun Aug 14 19:19:18 2022 daemon.notice procd: /etc/rc.d/S80umdns: Failed to parse message data
Sun Aug 14 19:19:19 2022 daemon.notice netifd: Interface 'lan' is enabled
Sun Aug 14 19:19:19 2022 daemon.notice netifd: Interface 'lan' is setting up now
Sun Aug 14 19:19:19 2022 daemon.notice netifd: Interface 'lan' is now up
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.097695] eth0: link up (1000Mbps/Full duplex)
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.106244] br-lan: port 1(eth0.2) entered blocking state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.111882] br-lan: port 1(eth0.2) entered disabled state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.117784] device eth0.2 entered promiscuous mode
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.122778] device eth0 entered promiscuous mode
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.127792] br-lan: port 1(eth0.2) entered blocking state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.133400] br-lan: port 1(eth0.2) entered forwarding state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.382805] br-lan: port 2(eth0.3) entered blocking state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.388445] br-lan: port 2(eth0.3) entered disabled state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.394311] device eth0.3 entered promiscuous mode
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.399462] br-lan: port 2(eth0.3) entered blocking state
Sun Aug 14 19:19:19 2022 kern.info kernel: [   29.405076] br-lan: port 2(eth0.3) entered forwarding state
Sun Aug 14 19:19:20 2022 daemon.notice netifd: bridge 'br-lan' link is up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Aug 14 19:19:20 2022 kern.info kernel: [   29.537887] br-lan: port 3(eth0.1) entered blocking state
Sun Aug 14 19:19:20 2022 kern.info kernel: [   29.543522] br-lan: port 3(eth0.1) entered disabled state
Sun Aug 14 19:19:20 2022 kern.info kernel: [   29.599766] device eth0.1 entered promiscuous mode
Sun Aug 14 19:19:20 2022 kern.info kernel: [   29.604913] br-lan: port 3(eth0.1) entered blocking state
Sun Aug 14 19:19:20 2022 kern.info kernel: [   29.610533] br-lan: port 3(eth0.1) entered forwarding state
Sun Aug 14 19:19:20 2022 daemon.notice netifd: 8021q 'eth0.1' link is up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: VLAN 'eth0.2' link is up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: VLAN 'eth0.3' link is up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Interface 'loopback' is enabled
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Interface 'loopback' is setting up now
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Interface 'loopback' is now up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Network device 'eth0' link is up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Network device 'lo' link is up
Sun Aug 14 19:19:20 2022 daemon.notice netifd: Interface 'loopback' has link connectivity
Sun Aug 14 19:19:22 2022 daemon.info procd: - init complete -
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671724] ath: EEPROM regdomain: 0x8020
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671732] ath: EEPROM indicates we should expect a country code
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671735] ath: doing EEPROM country->regdmn map search
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671738] ath: country maps to regdmn code: 0x3b
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671743] ath: Country alpha2 being used: AR
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671746] ath: Regpair used: 0x3b
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671752] ath: regdomain 0x8020 dynamically updated by user
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671829] ath: EEPROM regdomain: 0x8020
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671832] ath: EEPROM indicates we should expect a country code
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671835] ath: doing EEPROM country->regdmn map search
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671838] ath: country maps to regdmn code: 0x3b
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671841] ath: Country alpha2 being used: AR
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671844] ath: Regpair used: 0x3b
Sun Aug 14 19:19:22 2022 kern.debug kernel: [   31.671847] ath: regdomain 0x8020 dynamically updated by user
Sun Aug 14 19:19:24 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Sun Aug 14 19:19:24 2022 kern.info kernel: [   33.680330] br-lan: port 4(wlan1) entered blocking state
Sun Aug 14 19:19:24 2022 kern.info kernel: [   33.685872] br-lan: port 4(wlan1) entered disabled state
Sun Aug 14 19:19:24 2022 kern.info kernel: [   33.691702] device wlan1 entered promiscuous mode
Sun Aug 14 19:19:24 2022 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Sun Aug 14 19:19:24 2022 kern.info kernel: [   33.837020] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Sun Aug 14 19:19:24 2022 kern.info kernel: [   33.843878] br-lan: port 4(wlan1) entered blocking state
Sun Aug 14 19:19:24 2022 kern.info kernel: [   33.849428] br-lan: port 4(wlan1) entered forwarding state
Sun Aug 14 19:19:24 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Sun Aug 14 19:19:25 2022 kern.warn kernel: [   35.112723] ath10k_pci 0000:00:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Sun Aug 14 19:19:25 2022 kern.warn kernel: [   35.120606] ath10k_pci 0000:00:00.0: msdu-desc: 2500  skid: 32
Sun Aug 14 19:19:25 2022 kern.info kernel: [   35.196622] ath10k_pci 0000:00:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Sun Aug 14 19:19:25 2022 kern.info kernel: [   35.207943] ath10k_pci 0000:00:00.0: wmi print 'free: 31080 iram: 23028 sram: 9596'
Sun Aug 14 19:19:26 2022 kern.info kernel: [   35.560985] ath10k_pci 0000:00:00.0: rts threshold -1
Sun Aug 14 19:19:26 2022 kern.warn kernel: [   35.566720] ath10k_pci 0000:00:00.0: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Sun Aug 14 19:19:26 2022 kern.info kernel: [   35.583615] br-lan: port 5(wlan0) entered blocking state
Sun Aug 14 19:19:26 2022 kern.info kernel: [   35.589379] br-lan: port 5(wlan0) entered disabled state
Sun Aug 14 19:19:26 2022 kern.info kernel: [   35.595294] device wlan0 entered promiscuous mode
Sun Aug 14 19:19:26 2022 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Sun Aug 14 19:19:26 2022 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Sun Aug 14 19:19:26 2022 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ENABLED
Sun Aug 14 19:19:26 2022 daemon.notice hostapd: wlan1: AP-ENABLED
Sun Aug 14 19:19:26 2022 kern.info kernel: [   35.610815] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
Sun Aug 14 19:19:26 2022 kern.info kernel: [   36.259910] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:19:26 2022 kern.info kernel: [   36.280648] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sun Aug 14 19:19:26 2022 kern.info kernel: [   36.287499] br-lan: port 5(wlan0) entered blocking state
Sun Aug 14 19:19:26 2022 kern.info kernel: [   36.293071] br-lan: port 5(wlan0) entered forwarding state
Sun Aug 14 19:19:26 2022 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Sun Aug 14 19:19:26 2022 daemon.notice hostapd: wlan0: AP-ENABLED
Sun Aug 14 19:19:26 2022 kern.warn kernel: [   36.366509] ath10k_pci 0000:00:00.0: wmi: fixing invalid VHT TX rate code 0xff
Sun Aug 14 19:19:27 2022 daemon.notice netifd: Wireless device 'radio1' is now up
Sun Aug 14 19:19:27 2022 daemon.notice netifd: Network device 'wlan1' link is up
Sun Aug 14 19:19:27 2022 daemon.notice netifd: Wireless device 'radio0' is now up
Sun Aug 14 19:19:27 2022 daemon.notice netifd: Network device 'wlan0' link is up
Sun Aug 14 19:19:27 2022 kern.info kernel: [   37.284059] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:19:28 2022 kern.info kernel: [   38.307961] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
...
Sun Aug 14 19:21:43 2022 kern.info kernel: [  172.451908] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:21:44 2022 kern.info kernel: [  173.476052] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:21:49 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED HIDDEN_MAC
Sun Aug 14 19:21:52 2022 daemon.info hostapd: wlan1: STA HIDDEN_MAC IEEE 802.11: authenticated
Sun Aug 14 19:21:52 2022 daemon.info hostapd: wlan1: STA HIDDEN_MAC IEEE 802.11: associated (aid 1)
Sun Aug 14 19:21:52 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED HIDDEN_MAC
Sun Aug 14 19:21:52 2022 daemon.info hostapd: wlan1: STA HIDDEN_MAC RADIUS: starting accounting session A1A64C1E7E90CC2B
Sun Aug 14 19:21:52 2022 daemon.info hostapd: wlan1: STA HIDDEN_MAC WPA: pairwise key handshake completed (RSN)
Sun Aug 14 19:21:57 2022 kern.info kernel: [  186.787951] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:21:58 2022 kern.info kernel: [  187.812051] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
...
Sun Aug 14 19:33:27 2022 kern.info kernel: [  876.963915] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:33:28 2022 kern.info kernel: [  877.988057] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down

This up and down loop is also seen on luci gui. It changes in few secconds from "100baseT full-duplex" to "no link" without any fisical nor other change in the network:

And the kernel log is almost the same issue abouth Atheros going up and down. I didn't include it here because it exceds the post size.

Just to sum on more valuable information; I went back to stock (Tp link) firmware and it is working. Then went back to Openwrt, back to TpLink, back to Openwrt which is where I am right now.

Remove eth0.2 and eth0.3 from the bridge. Remove the empty bridge declaration and remove the ipv6 option.

Remove the code in rc.local. It is not necessary.

Reboot and test. Let us know if that helps.

Thanks for your help @psherman, I just did the changes and restarted but still the same, the luci gui shows the wire connection loop up and down as shown in the log:

Sun Aug 14 19:53:13 2022 kern.info kernel: [  128.163972] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:14 2022 kern.info kernel: [  129.188089] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:53:18 2022 kern.info kernel: [  133.283998] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:19 2022 kern.info kernel: [  134.308114] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:53:30 2022 kern.info kernel: [  144.547830] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:31 2022 kern.info kernel: [  145.571962] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:53:35 2022 kern.info kernel: [  149.667826] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:36 2022 kern.info kernel: [  150.691948] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:53:46 2022 kern.info kernel: [  160.931853] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:47 2022 kern.info kernel: [  161.955974] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:53:48 2022 kern.info kernel: [  162.979854] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:49 2022 kern.info kernel: [  164.003973] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:53:51 2022 kern.info kernel: [  166.051829] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:53:52 2022 kern.info kernel: [  167.075971] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:54:02 2022 kern.info kernel: [  177.315825] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:54:03 2022 kern.info kernel: [  178.340225] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:54:08 2022 kern.info kernel: [  182.435851] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:54:09 2022 kern.info kernel: [  183.460081] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:54:19 2022 kern.info kernel: [  193.699825] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:54:20 2022 kern.info kernel: [  194.724004] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
Sun Aug 14 19:54:24 2022 kern.info kernel: [  198.819899] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
Sun Aug 14 19:54:25 2022 kern.info kernel: [  199.843985] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down

Also is strange that the unit is feed by POE without the network disruption shown in the port. The switch shows the port as if no device was connected but it is feeding it! You may think there is a wire issue but I have a network tester and found no issue besides the Tp-link stock firmware works fine

You're right... that's where I am going next.

So yes, it is possible that the cable is fine, but it is possible that it is marginal or that there are issues you haven't noticed even with the stock firmware. Therefore, it is worth swapping with a known good cable (ideally a short one) just to be sure. The other thing is to inspect the physical connectors (the cable terminations, RJ45 jacks on the devices, and also if you have any intermediate connections like a patch panel). This is just good form in troubleshooting to rule out something that, if unchecked, could cause you to spend lots of time and effort chasing down every other possible culprit until you give up and try a new cable.

Also, are you using a PoE injector or a PoE switch?

1 Like

Thanks @psherman, I have a PoE managed switch (Zyxel GS1900-8HP) and just did the suggested test with an expensive gigabit short cable and now all is working and even better than ever! I can't believe it! It now shows "1000Mbps Full Duplex" whereas before showed "10Mpbs Full Duplex" or sometimes "100Mbps Full Duplex".

A month ago, I updated all network cables, and used a cheap cat 6 cable which I now realize is a very very bad cable I will have to update it again with an expensive one. Thanks a lot Psherman!

Glad I could help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.