TL-CPE220v3 Unstable Link

123

Hello, I just installed an openWrt with my TP Link CPE220v3 currently using the OpenWrt 19.07.1 (openwrt-19.07.1-ath79-generic-tplink_cpe220-v3-squashfs-factory.bin), and I find it better than the stock firmware. The problem is sometimes link keeps going down (as seen in attached image) then back to normal again, it affects my gaming ping. I also tried to install the latest stable which is Openwrt 19.07.2 but it seems much worse on that version because sometimes when I reconnect it only shows obtaining IP address on my phone and I have to replug the RJ45 cable in order to work again. Any remedy to this issue? Using it as Dumb AP.

P.S. I also tried this version "openwrt-ar71xx-generic-cpe220-v3-squashfs-factory.bin" and it got rid of the link issue and more stable but if it can be fixed with the latest version, I would be glad though.

EDIT: I think ath79 seems to have all this issue, like it suddenly shows obtaining IP address on all our phone and have to replug the RJ45 again to make it work plus LINK keeps going down and up again. AR7xx seems the way to go for now.