TL-1043ndV1 as a switch with 22.03.5

I know its old and not up to these day's standards, but it is still working and I believe it could work for what I want to do without buying another switch. But the old TL-1043nd seems to be missing something or I am missing something.

For the moment, I have the fresh installed configuration active, no nothing more/less. It is exactly as in here https://openwrt.org/docs/guide-user/network/network_configuration, minus that I have deactivated DHCP and made the br-lan interface a DHCP client while I am working on it.

The only thing I want to do with it is a managed switch, doubled with an access point. This will sit in a young one's bedroom to connect his wireless stuff and give ports for PC, PS4 and whatever other friends brings to play in the room. I would like to simply have vlan1 (management, untagged on the trunk) and another one (100) for him, untagged on all ports except the trunk one, where it would be tagged. Behind that, it comes in my realm and would go directly to the net. No need to discuss pass that point, its all good.

So the problem I have, I don't see the individual lan port on the device list, and when creating other vlan, it seem to apply it to all port and I thus loose connection to the router. Is it suppose to as such on 22.03.5?

I saw this post with this image https://forum.openwrt.org/uploads/default/original/3X/c/4/c4834df96034f1f32f6bb3288dfb501fa37c160a.png. This is what I was used to before upgrading to 22.03.5

Now, I have this

I am also wondering if it has anything to do with a comment someone made on this thread: https://forum.openwrt.org/t/solved-tp-link-tl-wr1043n-nd-v1-lan-settings/38059
and I quote:

The TL-WR1043NDv1 has a single CPU port (the internal connection between switch and CPU, through which all traffic that doesn't remain exclusively within the switch fabric (read, pure LAN internal traffic)) must pass through, all 4+1 ethernet ports are part of this switch. As a result it doesn't matter which way you assign the labels, the performance remains constant - all ports have exactly the same connection to the CPU and all routed/ NATed/ firewalled traffic has to go through the bottleneck of the CPU-port and be processed by the (by today's standards) very slow CPU, regardless of how you assign the labels WAN/ LAN between them.

Any lead explanation would be great.

Thanks.

Just look in the switch config screen (under network) -- that's where you setup the VLANs.

Or, post a description of your goals and the contents of your /etc/config/network config file.

As mentioned in my comment, my goal is:

I want to do a managed switch, doubled with an access point... I would like to simply have vlan1 (management, untagged on the trunk) and another one (100) for him, untagged on all ports except the trunk one, where it would be tagged.

Config is as exactly as in the example at the link, but here it is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9b:f6f1:0e1b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'

With that configuration, I only see this:

Plus the other image above in the switch configuration of br-lan.

We can take for granted I can do vlan with openWRT 22.03.5. :wink: as I have a WRT3200ACM setup with 6 working vlans.

What I cant understand is why I cannot see port 1 through 4 in the devices and in the br-lan so that I can associate vlan and tagging of those vlans.

Thanks.

The reason you can't see it is because this device uses swconfig -- everything is in the Network > Switch menu.

Take a look there and you'll see what I mean. If you still need help, I can show you with the text configs (modifying what you provided) how to configure a swconfig based device.

And be aware of two issues:

  • 32 MB RAM is very limited, even for your desired configuration (wireless needs RAM)
  • 22.03.x is going EOL within the next few (single digit) weeks, so upgrading is necessary (and yes, I am aware that there are no prebuilt 23.05.x images for the tl-wr1043ndv1, because of its RAM size)

As psherman noted, forget everything you know about DSA and bridge VLAN filtering, check up the (older-) swconfig specific configuration approaches instead.

:face_in_clouds:

Ok... I want to dissapear now. Took me so much time to get used to the new way of things that I forgot the old one...

Thanks.

I know its not big, and I sure would not put that as a router these days.

Is there a way, documentation of which services included OOTB are not needed for a Router to become a good Managed Switch and no more? The first time I got it to 22.03.5 I run the update/upgrade and when done, I was out of memory. I started looking at things installed but could not obviously see what was useless for the job I want it to play.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.