Tipps for initial setup that nobody bothers to tell you


Here are the initial steps and solutions for failures when installing OpenWRT on a Raspberry Pi 4:

  1. Download the OpenWRT image and flash it onto an SD card.
  2. Connect the Raspberry Pi's Ethernet port with the router, boot up the Raspberry Pi, and connect a keyboard. Press enter when prompted. (Note: This extra step is required for OpenWRT.)
  3. Set the network configuration. Connect to your router to see what IP address the Raspberry Pi has been assigned (e.g.
  4. Type the following commands in the terminal:
    • uci set network.lan.ipaddr=''
    • uci set network.lan.gateway=''
    • uci set network.lan.dns=''
    • service network restart
  5. Now, go to in your browser and enter the Luci admin interface by pressing enter (password can be changed later).

Hope this helps

Points 2 (other than connecting the rpi4 to the network) and 4 are unnecessary.

What failures are you trying to solve? Your 'solution' here is simply assigning an IP address, but this seems specific to only certain types of problems. What is the problem you encountered?

This is a very bad idea, and won't even work anyway.

The Pi's default configuration has the lan on the ethernet port (wifi disabled). OpenWrt uses a default address of, and the DHCP server is enabled on the lan. This means the following:

  1. connecting OpenWrt to an existing router/network would likely result in 2 DHCP servers running at the same time (bad)
  2. It would also potentially conflict with the upstream router's IP address (many routers use the same address)
  3. The Pi will not be issued an address because the lan is set to protocol 'static' by default. (not DHCP client)

Moving on, the static address assignment method as recommended in step 4 will likely be within the DHCP pool of the upstream network. This is to be avoided because it is possible that the upstream DHCP server could assign this IP to another device unless it has been 'reserved' on that DHCP server (in which case, there is no reason to statically assign it on OpenWrt).

There are many ways to configure OpenWrt, but I'd recommend avoiding the OP's recommendations.

With no problem statement, it is not clear what the OP is trying to solve. But this procedure is not going to work and may well cause more problems than it solves.