goose
December 18, 2024, 3:09pm
1
Tue Jul 16 00:03:51 2024 daemon.warn pppd[16496]: Timeout waiting for PADO packets
Tue Jul 16 00:03:51 2024 daemon.err pppd[16496]: Unable to complete PPPoE Discovery
No Internet. I assume because no PPoE. I've searched on the above error messages and there are some matches but I'm pretty unsure whether the comments apply to my situation. I have just purchased a Bt HH 5a with the latest OpenWrt installed. It's quite different from OpenWrt 18
This is its /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdde:8490:b1b4::/48'
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'
config dsl 'dsl'
option annex 'b'
option tone 'av'
option xfer_mode 'ptm'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr 'a0:1b:29:57:6f:00'
config device
option name 'lan2'
option macaddr 'a0:1b:29:57:6f:00'
config device
option name 'lan3'
option macaddr 'a0:1b:29:57:6f:00'
config device
option name 'lan4'
option macaddr 'a0:1b:29:57:6f:00'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'dsl0'
option macaddr 'a0:1b:29:57:6f:01'
config interface 'wan'
option device 'dsl0'
option proto 'pppoe'
option username 'bthomehub@btbroadband.com'
option ipv6 '0'
option password ' '
option peerdns '0'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
goose
December 18, 2024, 3:52pm
3
Thanks for your prompt reply. I'm not sure how to make that edit though
brada4
December 18, 2024, 3:56pm
4
config interface 'wan'
- option device 'dsl0'
+ option device 'dsl0.101'
option proto 'pppoe'
option username 'bthomehub@btbroadband.com'
option ipv6 '0'
option password ' '
option peerdns '0'
goose
December 18, 2024, 3:57pm
5
Oh, you mean edit the file directly? If so, I thought it was auto-generated and therefore shouldn't be edited directly. But I could be dreaming...
brada4
December 18, 2024, 3:59pm
6
You can edit field entering value in the entry box below selectable values.
goose
December 18, 2024, 4:40pm
7
You're a star! Thanks so much.
Now I've got to work out why my LAN speed has apparently dropped [when I hoped it would rise ]
brada4
December 18, 2024, 4:49pm
8
How do you measure LAN speed? IF it is lan-to-wifi the host CPU gets involved. But lan-lan transfers should work at gigabit up gigabit down independently of other stuff happening on CPU or wifi or DSL.
goose
December 18, 2024, 4:54pm
9
You might well ask. Since I could never find a really clear way to do that, I actually resorted to dd if=remote_big_file of=/dev/null
and looked at the result
brada4
December 18, 2024, 5:00pm
10
On one machine
iperf3 -s
On other machine
iperf3 --bidir -c ip_of_1st_machine
Runs even on android tv+termux
goose
December 18, 2024, 5:02pm
11
Well I was thinking about iperf but I didn't particularly want to have to install on both ends. But I'll give it a try now I think
goose
December 18, 2024, 5:10pm
12
Looks like 34.8 Mbits/sec. Currently using powerline networking. I'll try Wifi
Much slower on WiFi: 9.28 Mbits/sec
brada4
December 18, 2024, 5:55pm
13
Make 2 tests - one wired, other wifi
https://www.waveform.com/tools/bufferbloat
Post links.
iperf3 is just to unzip on windows or mac PC, nothing tough to install
Run bidirectional tests against one of https://iperf.fr/iperf-servers.php
And some info from your device:
ubus call system board
cat /etc/config/network # with final edits, still celar secrets
cat /etc/config/wireless
cat /etc/config/firewall
Obviously excluding powerlines.
goose
December 18, 2024, 6:22pm
14
brada4:
ubus call system board
{
"kernel": "5.15.162",
"hostname": "OpenWrt",
"system": "xRX200 rev 1.2",
"model": "BT Home Hub 5A",
"board_name": "bt,homehub-v5a",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.4",
"revision": "r24012-d8dd03c46f",
"target": "lantiq/xrx200",
"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
}
}
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdde:8490:b1b4::/48'
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'
config dsl 'dsl'
option annex 'b'
option tone 'av'
option xfer_mode 'ptm'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr 'a0:1b:29:57:6f:00'
config device
option name 'lan2'
option macaddr 'a0:1b:29:57:6f:00'
config device
option name 'lan3'
option macaddr 'a0:1b:29:57:6f:00'
config device
option name 'lan4'
option macaddr 'a0:1b:29:57:6f:00'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'dsl0'
option macaddr 'a0:1b:29:57:6f:01'
config interface 'wan'
option device 'dsl0.101'
option proto 'pppoe'
option username 'bthomehub@btbroadband.com'
option ipv6 '0'
option password ' '
option peerdns '0'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
option channel 'auto'
option band '5g'
option htmode 'VHT80'
option cell_density '0'
config wifi-device 'radio1'
option type 'mac80211'
option path 'pci0000:00/0000:00:0e.0'
option channel '11'
option band '2g'
option htmode 'HT20'
option cell_density '0'
option txpower '20'
config wifi-iface 'wifinet2'
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt23'
option encryption 'sae-mixed'
option key xxxxx
option network 'lan'
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt235G'
option encryption 'psk2'
option network 'lan'
option key xxxxx
config wifi-iface 'wifinet4'
option device 'radio1'
option mode 'ap'
option ssid 'OpenWrt-C11'
option encryption 'sae-mixed'
option key xxxxx
option network 'lan'
cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'HTTPS'
option src 'wan'
option src_dport '443'
option dest_ip '192.168.2.144'
option dest_port '443'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'SSH'
option src 'wan'
option src_dport '22'
option dest_ip '192.168.2.144'
option dest_port '22'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'HTTP'
option src 'wan'
option src_dport '80'
option dest_ip '192.168.2.144'
option dest_port '80'
The wireless is somewhat borked at the moment
brada4
December 18, 2024, 6:25pm
15
23.05.5 for better wifi (luci-app-attendedsysupgrade if you have extra packages added)
goose
December 18, 2024, 6:35pm
16
I haven't put my extra packages (adblock for one) in yet, so I suppose I could do an update if HH5a will take it
brada4
December 18, 2024, 7:40pm
17
You can complain as much as you want about self-inflicted damage in form of
powerline
version specifically known for sub-par wifi.
goose
December 18, 2024, 8:14pm
18
I have to say I'm circumspect about sysupgrade. The last time I did that with an HH 5a from OpenWrt 18.x to latest, the wireless ceased to work (or something broke in a major kind of way, I can't quite remember now). But you've been very helpful
brada4
December 18, 2024, 8:34pm
19
You are complaining about broken version that cuts download speed in half. If you upgrade too far ahead configs do not migrate. You need to upgrade 1 major version at a time.
goose
December 19, 2024, 12:08am
20
Yes, OK. I see. Can I be reasonably sure that if I do a backup of OpenWrt 23.05.4 I can be fairly certain I can revert to that working version? I usually generate an archive backup with the gui