There's no option available for UPnP in the Firmware

I usually play games (GTA-V Online, COD Warzone etc) . I was trying out OpenWRT for the first time. I don't have an public IP available but NAT-PMP / PCP & UPnP helps a lot to join sessions with my friends in gta-v online. I took a look at the frimware but could'nt find the option for NAT or UPnP settings. I saw many forums no one them seemed to work for me. I haven't even encountered any installations and configured every as per the forums said none worked. Is there any way I can trun on NAT & UPnP :smiley: TIA
image

install the miniupnpd package.

Keep in mind that upnp is often considered a security vulnerability that is voluntarily installed.

2 Likes


There's two of them available I installed the nftables one but still remained the same :frowning:

what is the output of:

ubus call system board


will this work. What you were asking I have no Idea :sweat_smile:

Use the nftables version since you are using 23.05.

hi,

are you comfortable with cli tools, ssh and vi?

if not, install luci-app-upnp on top of miniupnpd-nftables, and make sure to re-login to luci then you should see a new Upnp menu under Services. go there configure however you'd like and tick "Enable Upnp functionalities". otherwise it will not work for sure.

if you are comfortable with ssh access, go:

  • either run uci set upnpd.config.enabled=1 ; uci commit upnpd,
  • or edit /etc/config/upnp and set option enabled 1,

then run service miniupnpd restart in both case.

good luck.

1 Like