Theoretical maximum between WAX206 and MR90x

Hello, I have the "problem" that I want to get my 1GBit uplink into the other corner of my apartment without a cable.

I am meshing a MR90x (MediaTek MT7986) with a WAX206 (MediaTek MT7915E) and was wondering was the theoretical maximum would actually be on that hardware. I put them next to each other to see what is possible, I see the following parameters on the Mesh connection:


Do I read that correctly as 2x1.2Gbit on the connection? Because what I am measuring with iperf looks a lot less (directly on the routers):

[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  84.4 MBytes   708 Mbits/sec    0   1.48 MBytes       
[  5]   1.00-2.00   sec  85.0 MBytes   713 Mbits/sec    0   1.75 MBytes       
[  5]   2.00-3.00   sec  71.2 MBytes   598 Mbits/sec    0   1.96 MBytes       
[  5]   3.00-4.00   sec  83.6 MBytes   701 Mbits/sec    0   1.96 MBytes       
[  5]   4.00-5.00   sec  85.0 MBytes   713 Mbits/sec    0   1.96 MBytes       
[  5]   5.00-6.00   sec  71.2 MBytes   598 Mbits/sec    0   1.96 MBytes       
[  5]   6.00-7.00   sec  86.2 MBytes   724 Mbits/sec    0   1.96 MBytes       
[  5]   7.00-8.00   sec  85.0 MBytes   713 Mbits/sec    0   1.96 MBytes       
[  5]   8.00-9.00   sec  70.0 MBytes   587 Mbits/sec    0   1.96 MBytes       
[  5]   9.00-10.00  sec  87.5 MBytes   734 Mbits/sec    0   1.96 MBytes    

I know connectivity depends on a lot of factors, but they are next to each other, there is not so much going on the 5GHz band and I would expect more than a third of the actual Wifi speed on the TCP level. Where is the flaw in my way of thinking?

So the result is around 700Mb/s? Which doesn't look bad to me because you are using 80MHz channel width.

Try pushing more streams on the test, add "-P 4", and maybe try udp "-u"

99.9% of the time WiFi is half duplex, so anything better than half of your WiFi sync speed is good.

can you test 160MHz between the devices, that should give a much higher throughput.

I just now understood that this is RX/TX rate in the view. So ok, then it is clear.

Funnily enough both are already configured for 160 Mhz channels, on the Mesh as well as on the other Wifi running on the radio, apparently "something" decided that 80 Mhz is better. But that might be the WAX206, there were driver issues/discussions about the channel width if I remember correctly.

Probably due to country selection? My WAX206 has JP country code which can use 160MHz without problem, and some countries 160MHz might fall into DFS.

I figured as much, but even when playing with the country setting it does not change.

Funnily my phone works with the current settings with 2.1GBit (with the Mr90x and the Wax206), so it must be something in OpenWRT that limits channel width for the mesh.

1 Like

So just another thing: this is the configuration that is set on the Device, no:

phy#1
	Interface phy1-mesh0
		ifindex 11
		wdev 0x100000003
		addr 02:eb:d8:4a:ce:ed
		type mesh point
		channel 48 (5240 MHz), width: 80 MHz, center1: 5210 MHz
		txpower 23.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	733	0	0	0	4	177988		744
	Interface phy1-ap0
		ifindex 10
		wdev 0x100000002
		addr 00:eb:d8:4a:ce:ed
		type AP
		channel 48 (5240 MHz), width: 160 MHz, center1: 5250 MHz
		txpower 23.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	0	0	0	0	0	0		0

Why is it 80Mhz for the Mesh and 160Mhz for the AP? They are configured exactly the same, meaning that is the same radio.

Especially when that is the same config in /etc/config/wireless for the radio:

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option channel '48'
	option band '5g'
	option htmode 'HE160'
	option cell_density '0'
	option country 'DE'

I played a little with iw and see if I can change that, but I know to little of how this all works to get from the actual configuration file to the configured device. Is there something I could try to get that mesh to also use 160Mhz wide channels?

I am pretty convinced now that is a bug, I can obviously "link" the two with 160MHz when I do Client/AP (WDS) Connections.

Somewhere the channel width gets lost when configuring the Mesh.

Recommend you create an issue in OpenWrt github if you think this is a bug?

True, I did: https://github.com/openwrt/openwrt/issues/13880

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.