The prolific pl2303 cable is not recognized by the USB

The prolific pl2303 cable is not recognized by the USB of my router using openwrt, I already have the package kmod-usb-serial-pl2303 - 5.4.89-1 installed, is there any additional driver or package to install?

What does lsusb have to say about it ?

Doesn't say too much, only info about Devices and Buses, I also tried lsusb -v but it gave me the same output:
Bus 003 Device 001: ID 1d6b:0002
Bus 002 Device 002: ID 2c7c:0800
Bus 001 Device 001: ID 1d6b:0002
Bus 004 Device 001: ID 1d6b:0003
Bus 002 Device 001: ID 1d6b:0003
Bus 003 Device 005: ID 0403:6001

Would indicate it isn't a PL2303 at all.

1 Like

This is because I have the following scenario:

Router (USB) <--- PL2303_wire ---> [NULL_MODEM_ADP] <--- FTDI_FT232_adaptor ---> (USB) PC/Laptop

And the dmesg only recognize the FT232RL:

[1122333.009125] usb 3-1: new full-speed USB device number 5 using xhci-hcd
[1122333.167341] usb 3-1: Detected FT232RL
[1122333.173944] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB4

How can the router detect a FT233 USB TTL when it's not even attached to it ?

Tried swapping the RT232 and the PL2303 ?

1 Like

That's the point, I dont know what is going on and I tried swapping the RT232 and the PL2303 and didnt recognize any of them, it seems like my router only detect the cable attached to the PC .

This scenario works well and I can open a session in minicom to transmit data, but dmesg dont recognize any wire:
Router (USB) <--- FTDI_FT232_adaptor ---> [NULL_MODEM_ADP] <--- PL2303_wire ---> (USB) PC/Laptop

And in this scenario only recognize the FT232 wire and I cannot transmit data in minicom:
Router (USB) <--- PL2303_wire ---> [NULL_MODEM_ADP] <--- FTDI_FT232_adaptor ---> (USB) PC/Laptop

I know that it's such a weird situation and I dont have any other took to solve it.

That would suggest your FT232 is b0rked ?

Just out of curiosity, what would be the use case for such a setup?

That's not the case, in other scenario works fine, also I had checked dmesg output and I didn't see anything wrong about this wire

It's a provisional scenario that I'm working for my own, just for perform tests.

1 Like

How is this possible?

Judging from your description, one of the USB TTLs broken, or the USB port is.

I just have checked all USB ports and connected devices to all of them and I had no problem, I believe that the point is any some additional driver, or change the prolific pl2303 wire, but if in the reserve scenario works it seems that the clue is the first one

Does the ftdi adapter work on windows? I vaguely remember ftdi driver intentionally soft bricking fake ftdi chips.

To all, if you buy a new USB-to-Serial adaptor, do not get PL230x and FT232, because there are many fake ICs on the types, normally they work on Windows ok for a simple use, but still come with some driver issues comparing the original.

What chipset is good? CH340 and CP2102.

Disconnect the null modem wire. Plug only the device that you think is a PL2303 into the router USB port (again, with nothing connected to the serial side). Check the router log. If it still says FT232, that is the chip that you actually have and the simplest thing to do would be to install the appropriate kmod. The two drivers can be loaded at the same time and they will attach to whichever chip is plugged in.

Then, if it works, short the Rx and Tx pins, and you should be able to see your own writing in minicom or screen.

This is how real Prolific adapter is recognized:

root@OpenWrt:~# logread -f

/then plugging in/

Thu May  9 20:15:24 2024 kern.info kernel: [1927213.185779] usb 3-1.1: new full-speed USB device number 3 using ehci-platform
Thu May  9 20:15:24 2024 kern.info kernel: [1927213.436573] usb 3-1.1: New USB device found, idVendor=067b, idProduct=2303, bcdDevice= 3.00
Thu May  9 20:15:24 2024 kern.info kernel: [1927213.445122] usb 3-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Thu May  9 20:15:24 2024 kern.info kernel: [1927213.452682] usb 3-1.1: Product: USB-Serial Controller
Thu May  9 20:15:25 2024 kern.info kernel: [1927213.457948] usb 3-1.1: Manufacturer: Prolific Technology Inc.

or in dmesg output:

[1927213.185779] usb 3-1.1: new full-speed USB device number 3 using ehci-platform
[1927213.436573] usb 3-1.1: New USB device found, idVendor=067b, idProduct=2303, bcdDevice= 3.00
[1927213.445122] usb 3-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[1927213.452682] usb 3-1.1: Product: USB-Serial Controller
[1927213.457948] usb 3-1.1: Manufacturer: Prolific Technology Inc.

FTDI adapter works well on windows, the problem is that the prolific pl2303 wire only works on windows and it's not recognized by my router

I bought them on these links:
FTDI: https://www.amazon.es/DIGITUS-70156-Adaptador-Serial-negro/dp/B0030IT780/ref=sr_1_8?crid=Z4AUPITFPXK5&dib=eyJ2IjoiMSJ9.BS_gYes8Mf3OT6bKRz12SO6pKn58lEb2DKlFnNW1Z927C-tKPS53NxU7Uq7ZhjJ4ROrKn3HCPRgen96hGvEGf8WPe1bUGMgd9GAf_XG2sHgcZWHNpsMaYy06ZqJc4_XK7DXijxktk23kGqNMVwmty6LLEKChIrIsgctnfyt5sVb58RKZnT_L0O5xKrWZSrhpXxCmRxQJKOJHHmnFpFNp7Nn6CmZ-0gR7n_9Vic_poEj_wGDXFMYcSk45u7zsOvhZa-nJeZ2SVSzRyyLPDGUfhn3pXM5T9oQIyrZkEDW7hyw.UlElxHuFAJmQkd4TATnPmymJme0zQ5V2jsSY7TURjI0&dib_tag=se&keywords=usb+db9+macho+ftdi&qid=1710761262&s=electronics&sprefix=usb+db9+macho+ftdi%2Celectronics%2C106&sr=1-8

PL2303: https://www.amazon.es/CableDeconn-Adaptador-chipset-Prolific-adaptador/dp/B00VBOCUIO/ref=sr_1_4?crid=2Y2AAM7BLSFXK&dib=eyJ2IjoiMSJ9.Y9BQLfQa6eqKfdOLqNVlYbrKZRnjVf8-aq8OzmA-kZvzwds_s0HNQCqrqvfaZ9JaaQylMgyzRS9QLrkadwxzPQ_xs8tZOFYiFPVYQlGHdjXyTY_4KJbyNtNuO1iQmpaawoaQJjWGR5IfjBM-faXgKglO3bezfEH2z8PvOTTXMh3qLIKEGxxSt1Mrvuxc_OPP_vwttD084mizaxw4uts8fdvfqvsng3h0ZfeahgAb-UmyPN8iaJgMHRmDb37IKz-ZIkiBJnwnBZH3UnJAQ5DrP3Uy6Po5izXyYWwaMzdpwdc.8dtqHO2VLWYFUXgKNX2jAK8pMINfR82RyZazylAarlM&dib_tag=se&keywords=cable+usb+db9+hembra&qid=1710938992&s=electronics&sprefix=cable+usb+db9+hembra%2Celectronics%2C105&sr=1-4