The OpenWrt Firmware Selector

My packages list is the same one, and each time I request a build, the firmware selector serves me that build from a few days ago with old packages, instead of rebuilding. I tried modifying the list of packages and unexpectedly, the updated firewall4 package was included. Any help would be appreciated!

TP-Link Archer C50 V4 OpenWrt 22.03.2

*** SOLVED ***

Thank you Daniel and slh. I appreciate the help.

Jesus Daniel!!! Thank you for going the extra mile. I really appreciate it. I am paranoid; I freely admit it. I'm literally seeing a possible revolution happen around me!

My internet speed still sucks. I can’t really use anything. Although my download speed is 11 Mps, My upload speed is only 0.09 Mbps and that basically means I can’t use any service that is important for me. I.E. banking, medical, work, and communication with friends, significant others, colleagues, … Last and least in this case the streaming services I pay for that shall remain nameless, but there are 5 of them. I can’t even login to their websites to cancel my services until I’m back in the US. If I disconnect my VPN the service bumps up to 40 Mbps download and 27 Mbps upload; but only for local I R A N traffic; no international connection at all. Even if there was; my insurance, banking, work, streaming … etc won’t allow access originating from I r a n.

Thank you for the upload. I’ll get it just to be on the safe side. Openwrt is just a tiny bit faster than the router I have here; I hope that will bump me up to the threshold where I can do do some of the things I have to do for example my credit card payment, and contacting my parents doctors. Keeping my fingers crossed.

Thank you again. I really appreciate the help. You cut my stress in half.
Screen Shot 2022-10-22 at 8.45.34 AM

Thank you again!!! Wormhole is awesome!!! it was super fast.

The build is 5 days old now.
@mwarning Could you help?
Should I open an issue on GitLab?

I have nothing to do with the server. This is the realm of @aparcar
If this is a bug, then create an issue here:

That's what I thought. Thank you!

1 Like

Hi , Please add " Edit UCI Defaults " Or add " Custom script to run on first boot " Option.


Yeah that is a slow upload. Is it possible to access a VPS via RDP or VNC?

I was trying to build 19.07.10 with additional packages but it says "Unsupported branch: 19.07.10" :frowning:


Outdated release!
This OpenWrt release is no longer receiving updates. You should switch to a newer release.

1 Like

I know but I just can't get along with DSA and my swconfig setup with ebtables is something I really need for my isolated guest setup. That's why I'm still on 19.07...

There's a learning curve for sure with DSA but it is well worth it. No spare device you can test configurations on?

Hi guys, I'm trying to decrease the size of the final image
how to exclude some package for example remove IPv6 package with Customize installed packages?

I do have a spare DIR 860L but last time i've tested my vlan config with DSA it didn't worked out for me, I couldn't get a trunk port to work. I'm also not sure if my ebtable setup is compatible with the new firewall stuff. DSA really killed the OpenWRT vibe for me so far but I know that at some point I have to make the move to an recent OpenWRT build to stay up-to-date security wise!

Removing IPv6 support is a) not possible with the imagebuilder (would require building from source) and b) not a supported configuration anymore.

But it can drop IPv6 related packets. It does not refer to disabling IPv6 in ImageBuilder.

The result would still be a kernel with full IPv6 support, but no firewalling at all - result, wide open router with zero security via IPv6. DON'T EVER do this.

Keep IPv6 support enabled at build time, if you have to, disable IPv6 in the interface configuration - done. Yes, this 'wastes' a few dozen KB flash space, but you end up with a secure router.

When building fully from source (not possible with the imagebuilder), the IPv6 toggle is technically still present - but you will hit build errors for packages not being tested in this unsupported configuration, if you can - fix those, but don't expect anyone else to work on this (and as this toggle in known-broken, it's slated for removal, soon™).


This will happen if you disable IPv6 in the firewall. However, @castillofrancodamian probably meant to just remove odhcp6c and odhcpd-ipv6only which does not bring about any such risk.

odhcpd only affects if the clients behind the router are getting IPv6 addresses assigned, it does not affect the router itself. odhcp6c merely affects if the router requests a DHCPv6 lease, things like link local addresses (which might expose you to other customers of your ISP) or other freak accidents caused by missing sensible defaults being applied in the absence of IPv6 firewall support or missing sysctl settings not withstanding.

There is no safe way to remove IPv6 packages using imagebuilder. Safe approaches are only keeping the packages intact and merely disabling IPv6 on the interfaces or building a kernel from source that really doesn't support IPv6 support (increasingly hard and requires careful auditing that its really lobotomized).

1 Like

Does removing the odhcp6c and odhcpd-ipv6only packages hurt the firewall? Also in case you don't have IPv6 and the settings disabled?