The OpenWrt Firmware Selector

I added bugs on GitLab - and

Hi, since a RC release has been announced when I am posting:

It is better to include RC release to this firmware selector (now there are only snapshot and stable releases);

1 Like

This tool is quite cool but could you please add a package selector too so we can compile with selected packages included? -

This already exists :slight_smile: -- select your router, then click on the customize twisty and you can add your packages.

1 Like

Cool this one is lit, thanks.

anyone know there are issues with ?

same error

1 Like

Why hasn't the firmware selector bug been resolved. . . I will wait to download 21.03 with kmod-inc plugin, unfortunately I won't compile, 22.03RC4 doesn't work with shadowsocks, I'm anxious and frustrated

There is always the option to run imagebuilder yourself, locally, and not to depend on donated remote services.


Please advise how to use imagebuilder, I am a novice


can we use it on ubuntu in WSL2 in Windows too?

Or get a virtual server from one of the big cloud providers, they're usually free, at least for a while.
It's not going to be fast, but I guess you're not in a hurry.

that is from 2020, we have come a long way from WSL2 in 2020.

Seems like is down again as above.

Can we please get this fixed as its giving exactly the same error as a few weeks ago??


Same problem here, tried to customize packages contained in image but failed wit hthe same error message.

Had to run the imagebuilder on CLI. Please bring back

not sure what is going on with but it won't do a custom build for the basic package selection with one change (wpad-wolfssl instead of wpad-basic-wolfssl) for either NBG6817 or EX6100v2 for 22.03.0-rc5 - seems like it isn't getting a full package for the architecture package list: (this is the same error on the Ex6100v2)

cc: @aparcar

1 Like

I'm seeing the same error as lunarpool on multiple devices. I'm also seeing it when using the Imagebuilder locally. Error is occurring with all RC versions of 22.03.0 -- my guess is it's a package issue with libustream-wolfssl

I got it to build by replacing 'wpad-basic-wolfssl' with ' wpad-basic-openssl', 'libustream-wolfssl' with 'libustream-openssl'. If you use luci-ssl use luci-ssl-openssl instead.

Using openssl instead of wolfssl is a possible workaround until the problem is fixed, but one needs to know that is consumes more disk space which can be a problem on devices with small rom.

1 Like