The net.core.rmem_max sysctl limit needs to be raised

I'm getting the below error in my log and im guessing i can just add the line in to etc/sysctl.conf to sort it out ?
Is there any drawbacks or issues with this and will it override the conntrack settings set in etc/sysctl.d?


daemon.err nlbwmon[5368]: The netlink receive buffer size of 524288 bytes will be capped to 180224 bytes
daemon.err nlbwmon[5368]: by the kernel. The net.core.rmem_max sysctl limit needs to be raised to at least 524288 in order to sucessfully set the desired receive buffer size!
1 Like

This error is related to the UDP receive buffer size, whose current value is 180224 bytes (176k) and must be increased to 524288 bytes (512k). Try the following commands to check if the error will disappear before making permanent changes.

sysctl -w net.core.rmem_max=524288
sysctl -w net.core.rmem_default=524288
1 Like

(there is a bit of a chicken and egg phenomenon with this, but I can understand the maintainers choice not to mess with the system setting, you can background sleep restart the service if you like from rc.local ... you'll still get the error on first start... but after 'done' runs (loads your custom syctl), and you restart the service, it will be happy / use the larger values)

1 Like

Ifter increasing the buffer size as you suggested I now get out of memory errors with nlbwmon but I'm definatly not running out of memory, I even tried to up buffer to 10Mb and still the same error.

Mon Jan  3 12:18:24 2022 daemon.err nlbwmon[15167]: Netlink receive failure: Out of memory
Mon Jan  3 12:18:24 2022 daemon.err nlbwmon[15167]: Unable to dump conntrack: No buffer space available

syscontrol -a output states the buffer size and max size has been increased.