The issue of being unable to connect to the TFTP server on a WR30U router after flashing U-Boot provided by OpenWrt

I have a brand new WR30U router and I want to run OpenWrt on it. So, I performed the SSH unlocking operation on it first.
I used the U-Boot from https://firmware-selector.openwrt.org/?version=23.05.0&target=mediatek%2Ffilogic&id=xiaomi_mi-router-wr30u-ubootmod.

mtd write openwrt-********-.fip FIP

now power on
I can obtain the following via the serial port.

openwrt U-Boot 2023.07.02-OpenWrt-r23497-6637af95aa

But when I started tftpd64 on a computer with the firewall disabled and configured the paths correctly, my router showed this result.


At first, I thought I had connected the network interface of the WR30U incorrectly, so I tried all of its network interfaces, but it didn't work either.
Please help me, I want to recover it.

Post a screenshot of the TFTPd server you've set up for flashing.

1 Like


Here are my TFTP settings, IP address settings, and the ping status of my WR30U U-Boot console.

No matter which network port I use to connect via Ethernet to the WR30U, it seems that I cannot ping it.

did you turn off your windows firewall?

Yes, I completely disabled the Windows 10 firewall, and I'm not running any firewall.

have you tried the preloader file?

I'm currently trying the kernel file, but I haven't tried the preloader file yet.


If I choose option 5, it still displays "ARP Retry count exceeded; starting again." I suspect the network connection is not functioning at all.

what about option 8 and then using the preloader file?

Alright, I'll give it a try. But may I ask which preloader file I should use?

Presumably the preloader file form the list...

But, have you been following all of the instructions from the git commit?

Oh, I see. I didn't follow that step before your response.
After unlocking SSH, I ran the command mtd write /tmp/ubootmod-bl31-uboot.fip , but it only ran this one line. Is there still a way to recover?

No idea... never used this device.

I'm a beginner, and I often have wishful thinking. I'm deeply grateful for your help."

What directions were you following when you used the mtd write command?

I found an incomplete tutorial on the internet, and I didn't want to use the .fip file they had modified. So, I downloaded a similar .fip file from the official OpenWrt website and used that.

I couldn't find the webpage you shared; I must have been too foolish.

Yikes... that might be difficult to recover if the process wasn't even complete.

I have no idea if that will be okay or if you've bricked the device since the file is obviously not the one that was part of that other procedure.

I'd recommend that you find the maintainer for the tutorial that you used and send them a message to ask about recovery methods.

I've already inquired with the tutorial's author, and they are also quite frustrated with my wishful thinking.