The IP address of the provider is not updated

Not a very conscientious provider, he has static IP addresses and that the IP address is permanent, he wants an additional fee.
Those who do not want to pay additionally, the supplier changes the IP -address and happens twice a day, that is, the old IP remained in the router, and in fact a new one had to come.
Router IP Address itself does not update it until you reboot it and this was before, even before Openwrt firmware.
Tell me there is any option, solve this problem ?

What is the issue here, exactly? Do you lose your internet connection? Or you lose access to your router from outside?


+1 to @eduperez's questions... we don't know what the problem is, so we can't help you solve it.

Also, other really important bits of info you must provide:

  • What is the connection protocol on the wan (DHCP, PPPoE, Static IP)?
  • Is your OpenWrt router directly connected to the internet (i.e. a public IP on the OpenWrt wan), or do you have another router in front of OpenWrt (such as one provided by the ISP)?

I had a similar problem in the past.

I recommend to install the watchcat package. You can configure this program to check the internet connection and if it is lost restarting your wan interface.

Nevertheless you will have a 2-3 minutes interrupt of your internet access (depending on your check intervall).

1 Like

Thanks, but watchcat is not working correctly. You increase the time by 5 minutes, with a ping interval of 80 seconds, then it does not work. Sending pings every 30 seconds or one minute is not an option.

According to this site
there should be no problem with your cited values.

It would help, if you post your /etc/config/watchcat file.


I did send a ping every 30 minutes and reboot after 1 hour, it almost works, but it will do for the countryside, thanks for the tip!

You're welcome.