The current netgear builds bricked two of my routers! (R6220, R8000)

I have tried to upgrade to the most current firmware as determined by the firmware picker for the Netgear R6220 and Netgear R8000 and it bricked both of them. The first one is bricked to the point where I need to use a TTL serial cable to flash it and the second one is caught in a boot loop. Currently I am using wireless hotspot functionality on my phone for internet access but this is unacceptable. I need at least one of these two routers unbricked NOW! This by the way was with a "STABLE" build which is anything but if it bricked two routers.

Post your home address, and well send someone over ASAP, to fix the issue for you... no, wait.

Then you should probably keep using the stock fw.

2 Likes

OpenWrt is free software, provided AS-IS and without any warranty.

That said, we are happy to help, but we need more info.

To start...

  • What version of OpenWrt were you using before?
  • What exact file did you attempt to install on each of the units?
  • Did you keep settings when you did the upgrade?
2 Likes

The version I was using before on the R6220 was 19.07.5 and the previous firmware I was using on the R8000 was 22.03.5 with the files being flashed as follows. On the R6220 it was openwrt-23.05.0-ramips-mt7621-netgear-r6220-squashfs-factory.img and on the R8000 it was openwrt-23.05.0-bcm53xx-generic-netgear_r8000-squashfs.chk

This is the wrong image file for an upgrade... you should have used the sysupgrade image. You can try using tftp to recover.

This one is okay.

You didn't answer if you kept settings or not (only relevant for the R8000 at this point).

I have a backup for the R8000 files because I have a problem with the WIFI radios resetting once a month and in terms of the R6220 I tried the upgrade file at first but got a warning about metadata not being found so I canceled and then tried the factory firmware and that is where I got the problem. I have been trying TFTP but the router will not respond to ping requests and no packets of data are being received from it along with IP V4 connectivity not being available nor IP V6 connectivity.

Maybe it wasn't clear from the way I asked the question... when you ran the upgrade, you had the option of keeping the settings or allowing it to reset to defaults during the upgrade process. What did you choose?

This sounds like something else is wrong -- either hardware or a software misconfiguration (or possibly DFS related)... this is not expected behavior of OpenWrt.

Next time, look at the release notes, not just of the new version, but of the ones you skipped. Or better yet, come here and ask before you apply an upgrade that you're not certain about.

Turns out that your router went through the DSA transition in version 21.02 -- this should have been the first step of your upgrade path. The image metadata error may still have appeared, but it would have been expected and you could have safely proceeded. The upgrade from 19.07 > 21.02 should have worked, but the upgrade from 19.07 > 23.05 is not officialy supported and may or may not have actually worked (thus why the intermediate step). We could have told you that in advance of you applying the wrong firmware image.

IPv6 is probably not going to be running in tftp mode.
Did you read the directions in the link from the device page?

1 Like

I tried tftpd and it did not work but then I read about nmrpflash as another recovery method and have been trying to find information on how to use it as it is a command line utility and those can be a bit weird especially when ported from Linux to Windows.

It works fine on the r6220. I have used it several times. Just two advices:

  • use npcap version 1.60, I had issues with version 1.70+
  • try various timing between switching on the device and launching the command

You can even upload directly the Openwrt factory file. Once installed, don't restore any config backup. The device is using DSA and need to be reconfigure from scratch.

the V23.05.0 works fine on my r6220 :slight_smile:
very important with windows while trying to recover it
turn off the windows firewall or it won't work

1 Like

My R8000 build may of use to you:
https://forum.openwrt.org/t/fixed-23-05-0-netgear-r8000-build/175991

nmrpflash worked fine for me on Windows. After manually setting my IP to 192.168.1.10 in my network adapter settings, I ran the command in the command prompt and immediately pressed the power button on the R8000 to turn it on. The nmrpflash utility will time out if you wait too long to power-up the router after issuing the command.

It takes about a minute for it to time out. By the way I tried your build for the Netgear R8000 and it works, I am using it right now in fact. It flashed just fine from the browser interface but now there are issues with the two 5 GHz WIFI radios. I think a restart will solve that issue though but this looks like a winner to me. Update, a restart got the 5 GHz radios working and so far it is working. In fact this should become the mainline build for firmware revision 23.05 for this particular router. Update two, a restart did not solve the 5 GHz radio problem in the end like it seemed to. Both are still down while 2.4 GHz is working and I do need the 5 GHz radios because of the faster speed offered by 802.11ac compared to 802.11n which is the newest standard that 2.4 GHz can handle.

Good day, i have the same problem with my netgear r8000 but I'm not sure what to do to unbrick my router. Is it okay if I ask for your help with this. I just need the steps or every details to unbrick my router. Your help is very much appreciated.