The 802.11s mesh with OpenWrt success stories

I'd appreciate if fellow OpenWrt users who successfully run an encrypted 802.11s WiFi mesh could share some details about their setups, specifically:

  • what kind of OpenWrt hardware is in use,
  • what OpenWrt version is in use,
  • how stable the mesh is,
  • whether scheduled periodic reboots are needed,
  • whether you had to resort to any custom mesh tweaks beyond what's in the wiki.

I just spent several days trying to get an mt76-based mesh up and running, without much luck.

Eventually I bought a cheap Tenda Nova MW5c system (a proprietary Realtek chipset-based solution, AFAIK), plugged it in as a replacement for my homebrew OpenWrt-based mesh (in "bridge" mode), and it just works. That's something I haven't been able to achieve with OpenWrt, but I'm not ready to give up just yet :slight_smile:


Mesh worked for a while with snapshots on the RT3200, but then stopped working a long time ago. And reports surface now and then confirming the same. Otherwise one sees lots of reports of problems with mesh on various devices on this forum.

It seems mesh doesn't work well in OpenWrt but WDS does. So many of us just use WDS.


Thanks! I actually wanted to try WDS but it doesn't seem to be supported by my MediaTek-based devices (Wavlink WL-WN530HG4 and TP-Link Archer A6 v3).

At least, it isn't reported as supported by iw list, and my attempt to get it up and running as described in the wiki failed.

Edited, I've now tried WDS with the most recent snapshot on WL-WN530HG4 and it actually works. Thanks again for the hint. I'll leave it overnight to see how it goes.

1 Like