TFTP - communication administratively prohibited!

Hey folks
So I am trying to go back to stock firmware on an Archer c7 v5. I copied the file to the /var/lib/tftpboot on Fedora 34. I see the incoming read request from and the next packet that I see logged is an ICMP "communication administratively prohibited" in wireshark. There is no iptables or firewall configured in my system. I also keep seeing ARP query messages for that go unanswered.
Now what's stopping the response to And why is the Tp-link router not defaulting to . 88 ip?

1 Like

are there other devices on the same LAN, or just your Fedora and the router ?

Does the tftpd have rights to read the file?
Other than that I don't see how this topic is connected to OpenWrt, as from my understanding the tftp client on the (currently) OpenWrt router is trying to get a file but Fedora tftp server is not sending it.

1 Like

Fedora has firewalld that is enabled by default and relies on nftables:

sudo firewall-cmd --state; \
sudo firewall-cmd --add-service=tftp; \
sudo firewall-cmd --get-active-zones; \
sudo firewall-cmd --list-all

Thank You very much!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.