TEW692gr from Openwrt to original firmware

Was happy with Openwrt but after upgrading to the latest firmware my 5GHz radio has vanished.
I've searched this forum, edited config/wireless and flashed older builds, reflashed the newest build and tried a development build.
Now I think my best option is to revert to stock then flash Openwrt because the first time I did that everything worked well.

So what do I do, if anyone has tried it. Can I simply flash the OEM or is it more complicated?

You did not mention it, but you usually need to reboot the newer kernel. Looking at the device page, it does not seem you have any other documented recovery methods

1 Like

Pretty sure I did.
Well, I guess I am stuck. What's annoying as well is that the single radio won't find my network when I scan.It finds every other router in my neighbourhood but the signal broadcasting 5 metres away.

@Steupz, welcome to the community!

  • If you upgraded to a new version it's suggested that you not select keep settings...
  • If you did so, are you aware that OpenWrt has WiFi disabled by default?

Yes I am aware and enabled it. But feel free to point me in the right direction, perhaps I missed something.
At this stage my 5GHz radio is completely gone and my 2.4 simply won't connect.

The problem is that the 5GHz uses a chip that is somewhat poorly supported. The 2.4GHz is fine, but in my experience the 5GHz radio dies after a while.

To flash stock, you probably need to use a serial connection and tftp to upload the original stock (IIRC).

Thanks. I have done that procedure before with Linksys routers but I am waiting to see if anyone has done it with this particular router before I give it a go.
Thanks for the replies everyone, appreciate it.

I have done it once, because back in 2016 or so the builds for the TEW-692gr were kinda broken (would fail at boot). I remember it was not that painful. You can connect to the serial and check if you get an output, wouldn't do any harm.

1 Like