Telnetd program for openwrt

Hi ,

I am trying to enable telnet server for openwrt.
To establish a connection from a client, the server in openwrt needs to listen in port 23 [telnet port]. For that I need to install the tcpd program.
tcpd - access control facility for internet services.
How to install tcpd for openwrt.

It's recommended to utilize Dropbear preinstalled by default:

1 Like

Hi ,
Thanks for the reply.
Dropbear is already enabled.
Is there any specific package to enable in dropbear for tcpd?

It's not clear why you need to use an insecure protocol.

I know its an unsecured protocol. I just want to try out with telnet server enabled.
Is there any working steps?
Or any way to include tcpd program for openwrt.

TCPD is used to control other daemons, but OpenWrt does not use TCPD; instead, you have to install each daemon independently, you do not need TCPD to have TELNET.


when I tried the netstat command , I could see openwrt is not listening on port 23. Could you please help me with the daemons ? or the package needed to make the server listen on telnet port 23

You need to patch the BusyBox package as mentioned above.

1 Like

I tried above steps. All changes were applied. Still openwrt is not listening on port 23.
Any help is appreciated.

telnet: Unable to connect to remote host: Connection refused

Check the output:

find ${PATH//:/ } -name telnetd; busybox telnetd


1 Like

Basically for netstat -tlnp | grep 23 , the server should be listening on port 23 , right.? Its not happening.

1 Like
/etc/init.d/telnet enable
/etc/init.d/telnet restart

/# /etc/init.d/telnet enable
/# /etc/init.d/telnet restart
/# telnet localhost
telnet: can't connect to remote host ( Connection refused

Modify the init file and restart the service:

sed -i -e "/^\sif\s/,/^\sthen$/d;/^\sfi$/d" /etc/init.d/telnet

Did that. No change , same issue.
Bad luck!!

Well, it works for me:

# pgrep -f -a telnetd
8759 /usr/sbin/telnetd -F -l /bin/

# netstat -l -n -p | grep -e telnetd
tcp        0      0 :::23                   :::*                    LISTEN      8759/telnetd

I recompiled BusyBox with the following config:

cat << EOF >> .config

Then copy-pasted the init and login scripts from the wiki removing the startup checks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.