Td-wr1043 wan interface can't ping, mwan3 conf

hello to all,
i'm trying to setup my tp-link to run mwan3, and i think i got it quite right, except some minor things for which i need help.
the router was already configured with 2 wan ports and 3 separate subnets, so i just installed mwan3 i hoped it'd work.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8a:0f91:7e43::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ifname 'eth0.1'
        option ipaddr '192.168.2.1'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'b0:4e:26:69:92:b6'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option username 'user'
        option password 'password'
        option service 'Iskon'
        option delegate '0'
        option force_link '1'
        option ipv6 '0'
        option mtu '1492'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'b0:4e:26:69:92:b7'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'
        option vid '2'

config interface 'APP'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option delegate '0'
        option force_link '0'
        option dns '8.8.8.8 1.1.1.1'
        option type 'bridge'
        option ifname 'eth0.4'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 1'

config interface 'WAN2'
        option ifname 'eth0.3'
        option proto 'static'
        option ipaddr '192.168.2.19'
        option netmask '255.255.255.0'
        option gateway '192.168.2.10'
        option dns '8.8.8.8 8.8.4.4 1.1.1.1'
        option delegate '0'
        option force_link '0'
        option metric '20'

config interface 'APP2'
        option proto 'static'
        option delegate '0'
        option ipaddr '10.10.0.1'
        option netmask '255.255.255.0'
        option dns '8.8.8.8 8.8.4.4'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '4'
        option ports '0t 2'

i can ping google if i specify the eth0.2 and pppoe-wan interfaces, but i can't ping if i specify wan or WAN2 interfaces - i get "bad addres" response.
on the router overview page i get both wans as working (on the mwan status). also both wans work independently for their own lan subnets (connecting to lan1 i can go to the net via wan1, and connecting to lan2 i can go out via wan2).
connection tracking is turned on in firewall. routing works. but i can't get the router to ping out if i don't specify the ifname , and i think that's the reason why mwan3 is not working.
please help with that.
wan1 is dsl 30/7mbit, wan2 is dsl 20/3mbit. i need load balancing to get ~50/10mbit.
thanks

This entry in the LAN is not needed.

That is correct, ping will use the names of interfaces found in ifconfig not the uci names.

Have you added a rule in mwan3 for the local packets or only for the LAN subnets?

in the forums, i found a topic about mwan3 saying that the router should be able to ping out by specifying the uci network name. this is the topic:

i didn't undertand the last part of your question, so here you have the mwan3 config file

this is my mwan3 config.

root@Gargoyle:/etc/config# cat mwan3

config policy 'balanced'
        list use_member 'wan_m1_w3'
        list use_member 'wanb_m1_w2'
        list use_member 'wanb_m1_w2'
        list use_member 'wanb_m2_w2'
        option last_resort 'default'

config policy 'wan_only'
        list use_member 'wan_m1_w3'
        list use_member 'wan6_m1_w3'

config policy 'wanb_only'
        list use_member 'wanb_m1_w2'
        list use_member 'wanb6_m1_w2'

config policy 'wan_wanb'
        list use_member 'wan_m1_w3'
        list use_member 'wanb_m2_w2'
        list use_member 'wan6_m1_w3'
        list use_member 'wanb6_m2_w2'

config policy 'wanb_wan'
        list use_member 'wan_m2_w3'
        list use_member 'wanb_m1_w2'
        list use_member 'wan6_m2_w3'
        list use_member 'wanb6_m1_w2'

config globals 'globals'
        option mmx_mask '0x3F00'
        option local_source 'lan'

config interface 'wan'
        option enabled '1'
        list track_ip '8.8.4.4'
        list track_ip '8.8.8.8'
        list track_ip '208.67.222.222'
        list track_ip '208.67.220.220'
        option family 'ipv4'
        option reliability '2'
        option count '1'
        option timeout '2'
        option failure_latency '1000'
        option recovery_latency '500'
        option failure_loss '20'
        option recovery_loss '5'
        option interval '5'
        option down '3'
        option up '8'

config member 'wan_m1_w3'
        option interface 'wan'
        option metric '1'
        option weight '3'

config member 'wan_m2_w3'
        option interface 'wan'
        option metric '2'
        option weight '3'

config member 'wanb_m1_w2'
        option metric '1'
        option weight '2'
        option interface 'WAN2'

config member 'wanb_m2_w2'
        option metric '2'
        option weight '2'
        option interface 'WAN2'

config rule 'https'
        option sticky '1'
        option dest_port '443'
        option proto 'tcp'
        option use_policy 'balanced'

config rule 'default_rule'
        option dest_ip '0.0.0.0/0'
        option use_policy 'balanced'

config interface 'WAN2'
        option initial_state 'online'
        option family 'ipv4'
        list track_ip '8.8.8.8'
        list track_ip '192.168.1.1'
        option track_method 'ping'
        option reliability '1'
        option count '1'
        option size '56'
        option check_quality '0'
        option timeout '2'
        option interval '3'
        option failure_interval '5'
        option recovery_interval '5'
        option down '3'
        option up '3'
        option flush_conntrack 'never'
        option enabled '1'

tp

I don't think this is correct. It doesn't work on my router either.

root@xeli:~# ping -I wan www.in.gr
ping: bad address 'wan'
root@xeli:~# ping -I pppoe-wan www.in.gr
PING www.in.gr (213.133.127.245): 56 data bytes
64 bytes from 213.133.127.245: seq=0 ttl=56 time=16.890 ms
64 bytes from 213.133.127.245: seq=1 ttl=56 time=16.606 ms
^C
--- www.in.gr ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 16.606/16.748/16.890 ms

For the local device read here:
https://openwrt.org/docs/guide-user/network/wan/multiwan/mwan3#the_routable_loopback_self_deprecated
But you already have the local source in your config.
Which versions of Openwrt/LEDE and mwan3 are you running?

i have OpenWrt 18.06.1 r7258.
mwan is the latest on the repository, i installed it yesterday.

ok, so since its not working, there should be a problem in the mwan cnfig. the network part should be ok like this, because everything else is working normally.
i edited the mwan via luci, but i don't see that changes in the mwan config file.

Another mistake I just noticed is that you use the same subnet in LAN and WAN2 (192.168.2.0/24). They must be different. Also make sure you removed the gateway from LAN.

1 Like

it's a bit complicated.
the 2nd modem is connected to the same switch with the rest of the network, it's reachable on 192.168.2.10, and connected to wan2 port on the tp-link, routing it's own traffic onto lan2. but it's also reachable from any other place on the network. it's used for manual failover, if my main dsl dies, i just manually change the gateway ip on the computers and use the 2nd modem as gateway for the time while the 1st dsl is down.
i can do it for testing if it would make mwan work, but not sure i could leave it in a different subnet for a longer time, as i'm serving a bigger network consisting of 4 houses.

But the whole point of having the mwan3 with dual WANs is to provide automatic failover to your network in case one WAN goes down. So maybe you need to think again of the topology and allocate the addresses in a way that they don't collide, because you currently have 2 interfaces in the same subnet that are not bridged and this can only cause problems.

1 Like

i did change subnet for test, gave the 2nd modem 192.168.3.10, and changed the setup on tp-link wan2 port to 192.168.3.10. unfortunately mwan3 didn't work, i still had 30mbit. i don't know what more to do with mwan, because it should have worked. i returned the network settings back to how they were before after testing.

my current network config has been working quite well for the last 5 years , i always had 2 dsl lines available at the same time. as said, it's 4 houses sharing the same network, with 2 dsl lines.
the only new thing is the tp-link router with openwrt (that replaced 3 other routers doing the same work, just independently - so this was of a great help in reducing the network mess). getting mwan to work would help me even more.

If you expect to get the aggregated speed of both lines in a download with one flow or speed test, it won't work. You need to test with a torrent that opens many connections or a download manager.

eh, i tried it. torrent with a lot of seeds, and speedtest with multi connection. it always capped at speed of my 1st dsl (32mbit max, torrent max 3.8MB/s).
also i noticed that after a while i would loose network connectivity (i could ping ip, but not website). ip services like p2p or rdc were working, but i couldn't load any webpage. the moment i stop the mwan service, it would come back to life.

i have just the balance rule in mwan, i deleted all others. still didn't help me.

would be nice if someone else joined the topic who have more experience in setting it up.
thanks

you have several times wanb on "balanced"... that probably makes some troubles.
please, try everything again with a more "simple" scheme and then keep adding your desired configurations step-by-step to see what it fails.
also, you should have DIFFERENT metric on each policies, if you use on "balanced" wan with metric 1, you should use metric 2 for wan2.

this was the default that came with mwan, i just deleted or changed parts where was wanb (in luci), replaced with WAN2. i don't know how to edit the config via telnet, i mean, i know how to use the vim editor, but i don't know what parts to edit.